Bug 429157 - No sound if boot with both tty & serial console (ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card)
No sound if boot with both tty & serial console (ALSA lib pcm_hw.c:1207:(_snd...
Status: CLOSED DUPLICATE of bug 359361
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-17 12:00 EST by Hann-Huei Chiou
Modified: 2009-01-07 13:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 14:39:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
killall -9 pulseaudio; pulseaudio -vvv (9.37 KB, text/plain)
2008-02-29 13:19 EST, Hann-Huei Chiou
no flags Details
results of "ck-list-sessions" (255 bytes, text/plain)
2008-02-29 13:20 EST, Hann-Huei Chiou
no flags Details
results of "getfacl /dev/snd/* (1.53 KB, text/plain)
2008-02-29 13:21 EST, Hann-Huei Chiou
no flags Details

  None (edit)
Description Hann-Huei Chiou 2008-01-17 12:00:33 EST
Description of problem:
If we boot with both tty/serial console, say, specifying "kernel
/vmlinuz-2.6.23.9-85.fc8 ro root=/dev/VolGroup00/LogVol00 rhgb quietconsole=tty
console=ttyS0,9600n8" in grub.conf, there are no sounds in gnome;
gnome-volume-manager will be marked with a "X"; and there are 2 lines of "ALSA
lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card" twice in
~/.xsession-errors;  mpg321 can't use esd to  play mp3 files.

In system-config-soundcard, the SBLive! is recognized and  sound-sample.wav is
played correctly.

Removing "console=tty console=ttyS0,9600n8" brings everything back to normal.


Version-Release number of selected component (if applicable):
alsa-lib-1.0.15-1.fc8.i386.rpm
alsa-plugins-pulseaudio-1.0.14-5.fc8.i386.rpm
alsa-utils-1.0.15-1.fc8.i386.rpm
bluez-utils-alsa-3.20-4.fc8.i386.rpm
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8.i386.rpm
pulseaudio-0.9.7-0.17.svn20071017.fc8.i386.rpm
pulseaudio-core-libs-0.9.7-0.17.svn20071017.fc8.i386.rpm
pulseaudio-esound-compat-0.9.7-0.17.svn20071017.fc8.i386.rpm
pulseaudio-libs-0.9.7-0.17.svn20071017.fc8.i386.rpm
pulseaudio-libs-glib2-0.9.7-0.17.svn20071017.fc8.i386.rpm
pulseaudio-module-gconf-0.9.7-0.17.svn20071017.fc8.i386.rpm
pulseaudio-module-x11-0.9.7-0.17.svn20071017.fc8.i386.rpm
pulseaudio-utils-0.9.7-0.17.svn20071017.fc8.i386.rpm


How reproducible:
Everytime


Steps to Reproduce:
1. Add "console=tty console=ttyS0,9600n8" to kernel parameter line in grub.conf
2. reboot

  
Actual results:
no sound in gnome; g-v-m is marked with a "X"; s-c-s can detect soundcard and
play sound


Expected results:
playing sound via PulseAudio

Additional info:
Comment 1 Hann-Huei Chiou 2008-01-17 21:54:23 EST
After upgrade pulseaudio rpms to 0.9.8-4.fc8.1, the problem still exists:

ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM front:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround40:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround41:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround50:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround51:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround71:0
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card

these messages appeared twice in ~/.xsession-errors.

Maybe it's not pulseaudio's fault, it belongs to alsa-lib or console permissions
(f-u-s-a) ?
Comment 2 Lubomir Kundrak 2008-02-28 13:02:40 EST
Please kill pulseaudio if it's running, try to start it again with "pulseaudio
-vvv" and attach the log.

Also, please paste output from "ck-list-sessions" and "getfacl /dev/snd/*"
Comment 3 Hann-Huei Chiou 2008-02-29 13:19:36 EST
Created attachment 296395 [details]
killall -9 pulseaudio; pulseaudio -vvv
Comment 4 Hann-Huei Chiou 2008-02-29 13:20:59 EST
Created attachment 296396 [details]
results of "ck-list-sessions"
Comment 5 Hann-Huei Chiou 2008-02-29 13:21:54 EST
Created attachment 296397 [details]
results of "getfacl /dev/snd/*
Comment 6 Hann-Huei Chiou 2008-02-29 13:26:07 EST
all rpms are upgraded to latest (stable) version...

From the results of "getfacl /dev/snd/*", the user is "gdm" not me. why? bug of
console-kit-daemon?
Comment 7 Lubomir Kundrak 2008-02-29 14:39:13 EST
Session1:
	uid = '1001'
	realname = 'Hann-Huei Chiou'
	seat = 'Seat1'
	session-type = ''
===>	active = FALSE	<===
	x11-display = ':0'
	x11-display-device = '/dev/tty7'
	display-device = ''
	remote-host-name = ''
	is-local = TRUE
	on-since = '2008-02-29T18:07:15Z'

That's it. I have hit the same problem whilst having a serial console.
Fix is pending, feel free to get it
https://admin.fedoraproject.org/updates/F8/FEDORA-2008-1549

Please reopen if it didn't fix your problem.

*** This bug has been marked as a duplicate of 359361 ***

Note You need to log in before you can comment on or make changes to this bug.