Bug 429197 - RFE: anaconda should remember disk choices when creating disk partitions
RFE: anaconda should remember disk choices when creating disk partitions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: AnacondaStorage
  Show dependency treegraph
 
Reported: 2008-01-17 16:33 EST by Michal Jaegermann
Modified: 2009-09-03 06:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 06:52:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-01-17 16:33:17 EST
Description of problem:

Say that one creates a RAID array from a number of disks and for
whatever reasons a particular partion layout is required of every
of those disk.  So one start with, say, /boot and unchecks all
disks but sda, created that partitions and goes to the next one.
Oops!  All available disks are checked in by a default for that
one again.  So uncheck, uncheck, uncheck ... and da capo al fine.
With 24 disks around (the real life scenario) this is getting old
pretty quickly.

A way to make anaconda to remember current disk choices until
explicitely changed would be extremely desirable.  The second
best option would be a switch to make _all_ disks unselected by
default when starting with a new partition.

Yes, personally in such situation I would rather script partitioning
across all devices (although a need to specify END when creating
partitions in parted, and this detail that END cannot be set
"too high" - or at least by not too much, is a serious PITA) but
various people doing actual installations are really hard to
persuade to take that approach; especially when GUI tools are
somehow available.
Comment 1 Andy Lindeberg 2009-07-09 15:44:13 EDT
Our storage code has undergone a pretty big rewrite since this bug was filed. Is it still a problem in F11?
Comment 2 Joel Andres Granados 2009-09-03 06:52:58 EDT
anaconda 12-20 has all the disks unselected by default.  I don't thing remembering what the user selected is where we want to go with this dialog.  The main reasoning behind this, is the fact that the whole layout may change with user interaction.  So a disk choice configuration might not be valid the next time the user pushes new.

Note You need to log in before you can comment on or make changes to this bug.