This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 429228 - nautilus-open-terminal opens terminal with pwd $HOME/Desktop
nautilus-open-terminal opens terminal with pwd $HOME/Desktop
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus-open-terminal (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Paul W. Frields
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-17 20:53 EST by John Ellson
Modified: 2008-03-20 20:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-20 19:59:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2008-01-17 20:53:48 EST
Description of problem:
nautilus-open-terminal opens terminal with pwd $HOME/Desktop instead of $HOME

Version-Release number of selected component (if applicable):
nautilus-open-terminal-0.8-3.fc9.x86_64

How reproducible:
100%

Steps to Reproduce:
1.open terminal from right click menu on gnome desktop
2.
3.
  
Actual results:
opens with pwd $HOME/Desktop

Expected results:
open with pwd $HOME

Additional info:
I think this is a regression in the latest release.
Comment 1 Brian Tate 2008-02-01 22:13:05 EST
It looks like ubuntu folk pushed a patch upstream to enable this "feature"
https://bugs.launchpad.net/ubuntu/+source/nautilus-open-terminal/+bug/63564

Rather then push a patch upstream to reclaim the proper feature perhaps some
sort of option should be of existence in gconf. Changing
/etc/gconf/schemas/nautilus-open-terminal* did nothing. 

Ever since I have ever used a gnome desktop I've expected right clicking and
hitting terminal to open on the desktop to open up in my home directory. That is
expected functionality. Back in the day before nautilus open terminal this was
the functionality; I don't see why opening it into ~/Desktop and then
immediately typing "cd .." is better. 
Comment 2 Paul W. Frields 2008-03-20 19:59:58 EDT
This is documented in the release notes that will come with Fedora 9:

http://fedoraproject.org/wiki/Docs/Beats/PackageNotes

I'm not sufficiently convinced this is a "bug" to argue it upstream, but I would
encourage motivated people to do so.  The text on the popup menu has even been
changed to note "Open in Terminal," denoting that you're not just opening a
terminal, you're opening the Desktop in one.
Comment 3 Brian Tate 2008-03-20 20:48:35 EDT
yeah now that there is a gconf option I would agree with you. Initially back in
Feb, the rawhide package didn't have a gconf option(or atleast one that worked
if memory serves correctly) 

I just tested it in my rawhide setup and the gconf-key does indeed toggle
between the two behaviors. 

Note You need to log in before you can comment on or make changes to this bug.