Bug 429230 - GCC4 Compiler compilation bug
GCC4 Compiler compilation bug
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-17 21:39 EST by opensourcenut
Modified: 2008-01-23 09:09 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 09:09:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description opensourcenut 2008-01-17 21:39:56 EST
Description of problem:
While attempting to compile GDC (GNU D Compiler) I discovered a bug in the
current version of GCC. Running the command 'gcc --version' claims GCC is
version 4.1, as well does checking my RPM version of gcc. This was to be
expected, however the unexpected part was that while compiling gdc, the failure
reported there was a problem with the symbol tables.

Having run strings on /usr/lib64/libstdc++.so.6.0.8 it reported the following:
GCC_4.2.0
GCC_3.3
GCC_3.0

I'm fairly certain this is due to backporting of patches from GCC 4.2 to GCC
4.1. So far, this is the only time I've encountered this problem, but it may
have some nasty side-effects in other applications that have been as of yet unseen.

How reproducible:
100%

Steps to Reproduce:
1. Compile GDC
2. Fail.
Comment 1 Jakub Jelinek 2008-01-23 09:09:36 EST
The @GCC_4.2.0 symbols are supplied by the included libgcc_s.so.1.
If GDC includes its own libgcc_s.so.1 which overrides the system one, it is buggy
and should be fixed.

Note You need to log in before you can comment on or make changes to this bug.