Bug 429235 - udunits tries to put libs in lib64 for ia64
udunits tries to put libs in lib64 for ia64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udunits (Show other bugs)
rawhide
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-01-17 23:26 EST by Doug Chapman
Modified: 2008-03-10 22:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 22:29:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-01-17 23:26:42 EST
Description of problem:
The udunits spec file has a patch that sets LIBDIR to $(exec_prefix)/lib64 on
all 64 bit arches:


# Yes, this is a dirty hack.
%ifarch x86_64 ppc64 sparc64 ia64
%patch1 -p1
%endif

this is actually incorrect for ia64.  Since ia64 ONLY has 64 bit libs it does
not have a /usr/lib and /usr/lib64 directory, it only has /usr/lib.  Please
remove ia64 from this line.

thanks,

- Doug



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom "spot" Callaway 2008-03-10 22:29:03 EDT
Fixed in udunits-1.12.4-15.fc9

Note You need to log in before you can comment on or make changes to this bug.