Bug 429248 - rgmanager restart previously stopped services
rgmanager restart previously stopped services
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 04:09 EST by Fabio Massimo Di Nitto
Modified: 2009-04-16 18:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 14:36:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
make help not suck (3.96 KB, patch)
2008-01-18 14:35 EST, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Fabio Massimo Di Nitto 2008-01-18 04:09:44 EST
Description of problem:

rgmanager restart previously stopped services

Version-Release number of selected component (if applicable):

rgmanager from cvs HEAD. mostlikely applies to other released branches as well.

How reproducible:

always

Steps to Reproduce:
1. test cluster as described in the wiki
2. start rgmanager all nodes but one
3. stop one service (clusvcadm -s service_128)
4. start rgmanager on the only node that did not start previously

Actual results:

the service is started again.

Expected results:

the service should not start as it was previously stopped manually.
Comment 1 Lon Hohberger 2008-01-18 10:54:02 EST
Stop = "stop until next transition of (service | rgmanager) then re-evaluate"

Typically, rgmanager moves services to this state if a dependency is unsatisfied
or restricted-failover domain is offline.  Every service state change or node
state change triggers an evaluation to see if the service has become runnable.

Disable = "stop until administrator intervention"

Service is not restarted.  Unless re-enabled by an administrator with -e (or the
admin did an explicit enable in a RIND event script, which I consider bad form,
but is legal)


Try - clusvcadm -d instead of clusvcadm -s?
Comment 2 Fabio Massimo Di Nitto 2008-01-18 13:07:27 EST
Ok in this case it makes perfect sense and this is not a bug.

For some reason I would expect a manual stop to be an alias for disabled or at
least this is how i read it via clusvcadm -h

Fabio
Comment 3 Lon Hohberger 2008-01-18 14:35:57 EST
Created attachment 292188 [details]
make help not suck
Comment 4 Lon Hohberger 2008-01-18 14:36:51 EST
Moved to upstream cvs

Note You need to log in before you can comment on or make changes to this bug.