This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 429275 - Text files aren't printed
Text files aren't printed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: paps (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 08:37 EST by Horst H. von Brand
Modified: 2008-02-01 04:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-01 04:20:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Requested "lpstat -s" output (186 bytes, text/plain)
2008-01-18 13:40 EST, Horst H. von Brand
no flags Details
The requested output (25.80 KB, text/plain)
2008-01-21 07:33 EST, Horst H. von Brand
no flags Details
Requested error_log (29.09 KB, text/plain)
2008-01-21 07:39 EST, Horst H. von Brand
no flags Details
Output of "lpstat -t" (493 bytes, text/plain)
2008-01-21 09:35 EST, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2008-01-18 08:37:36 EST
Description of problem:
When printing a plain text file:

  lpr TEXT

it shows up as a job for lpq(1), and then dissapears without being printed out.

Version-Release number of selected component (if applicable):
cups-1.3.5-1.fc9

How reproducible:
Always


Steps to Reproduce:
1. lpr random-text-file
2.
3.
  
Actual results:
Nothing printed

Expected results:
Printout

Additional info:
Comment 1 Tim Waugh 2008-01-18 09:29:13 EST
What does 'lpstat -s' say?
Comment 2 Horst H. von Brand 2008-01-18 13:40:06 EST
Created attachment 292184 [details]
Requested "lpstat -s" output

In any case, other types of stuff (did PS, PDF recently) prints OK.
I fixed the permissions problem on the USB device by hand (see BZ 429000).
Comment 3 Tim Waugh 2008-01-19 13:43:06 EST
1. Enable debugging output:
cupsctl --debug-logging
2. Stop cups:
/sbin/service cups stop
3. Clear out the error_log file:
>/var/log/cups/error_log
4. Start cups:
/sbin/service cups start

Now submit your print job as before and wait for 1 minute.  Then please attach
the /var/log/cups/error_log file to this bug report.
Comment 4 Horst H. von Brand 2008-01-21 07:33:50 EST
Created attachment 292358 [details]
The requested output
Comment 5 Horst H. von Brand 2008-01-21 07:39:23 EST
Created attachment 292359 [details]
Requested error_log

There was more output after the first I sent in.
Comment 6 Tim Waugh 2008-01-21 07:49:21 EST
What does 'lpstat -t' say?
Comment 7 Horst H. von Brand 2008-01-21 09:35:33 EST
Created attachment 292374 [details]
Output of "lpstat -t"
Comment 8 Horst H. von Brand 2008-01-21 09:36:46 EST
BTW, I just printed out a couple of webpages (through the net, even). No hitch.
It only hates textfiles.
Comment 9 Tim Waugh 2008-01-21 09:57:59 EST
Try this:

lp -o document-format=application/x-shell README

What happens?
Comment 10 Horst H. von Brand 2008-01-21 10:30:25 EST
Prints just fine.
Comment 11 Tim Waugh 2008-01-21 10:40:28 EST
What does 'rpm -q paps' say?
Comment 12 Horst H. von Brand 2008-01-21 12:12:37 EST
paps-0.6.8-3.fc9.x86_64 (rpm(1) configured to show the arch too)
Comment 13 Tim Waugh 2008-01-21 12:37:11 EST
Reassigning as it seems to be a paps problem.  I'll try to take a closer look at
this later in the week.
Comment 14 Horst H. von Brand 2008-01-21 15:42:07 EST
Looks that way, paps generates a .ps that crashes ghostscript, presumably the
interpreter in the printer goes south too.
Comment 15 Akira TAGOH 2008-01-22 21:02:00 EST
ok, confirmed a problem. trying to get a fix.
Comment 16 Akira TAGOH 2008-01-22 21:28:34 EST
should be fixed in paps-0.6.8-4.fc9.
Comment 17 Tim Waugh 2008-01-23 11:51:37 EST
Doesn't work for me.  I get this stack trace when trying 'lp /etc/fstab':

D [23/Jan/2008:16:49:22 +0000] [Job 2] Error: /rangecheck in --cvs--
D [23/Jan/2008:16:49:22 +0000] [Job 2] Operand stack:
D [23/Jan/2008:16:49:22 +0000] [Job 2] last_x   7416   (0)
D [23/Jan/2008:16:49:22 +0000] [Job 2] Execution stack:
D [23/Jan/2008:16:49:22 +0000] [Job 2] %interp_exit   .runexec2   --nostringval-
-   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --
nostringval--   --nostringval--   false   1   %stopped_push   1905   1   3   %op
array_pop   1904   1   3   %oparray_pop   1888   1   3   %oparray_pop   1771   1
   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringv
al--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--  
 --nostringval--   --nostringval--   %loop_continue   --nostringval--   --nostri
ngval--   --nostringval--   --nostringval--
D [23/Jan/2008:16:49:22 +0000] [Job 2] Dictionary stack:
D [23/Jan/2008:16:49:22 +0000] [Job 2] --dict:1166/1684(ro)(G)--   --dict:1/20(G
)--   --dict:77/200(L)--   --dict:31/42(L)--   --dict:7/11(L)--   --dict:13/21(L
)--   --dict:39/42(L)--   --dict:39/42(L)--
D [23/Jan/2008:16:49:22 +0000] [Job 2] Current allocation mode is local
D [23/Jan/2008:16:49:22 +0000] [Job 2] GPL Ghostscript 8.61: Unrecoverable error
, exit code 1
Comment 18 Horst H. von Brand 2008-01-23 16:39:03 EST
Running paps-0.6.8-4.fc9 here (i686) now gives a .ps that doesn't crash gs
(ghostscript-8.61-6.fc9), both with my original file and my /etc/fstab here. I
am away from the machine that couldn't print, so I can't check if the original
problem is gone.
Comment 19 Akira TAGOH 2008-01-23 18:48:16 EST
(In reply to comment #17)
> Doesn't work for me.  I get this stack trace when trying 'lp /etc/fstab':

That works for me. please make sure if you are using the above version of paps.
from the operand stack, that looks like the older version of paps.
Comment 20 Tim Waugh 2008-01-24 05:40:42 EST
Yes, I must have been looking at the wrong machine or something.  Works for me,
thanks.
Comment 21 A S Alam 2008-02-01 04:20:03 EST
it is working fine with following vesion:
paps-0.6.8-4.fc9.i386

Note You need to log in before you can comment on or make changes to this bug.