Bug 429278 - OOo writer italic format problem..
OOo writer italic format problem..
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 08:49 EST by lm
Modified: 2008-06-25 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.3.0-6.14.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:41:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 81764 None None None Never

  None (edit)
Description lm 2008-01-18 08:49:10 EST
Description of problem:
sometimes if i give an italic (less often bold) format, it happen that i can't
remove this format. the only way is to select a part of text.

Version-Release number of selected component (if applicable):
OOo-2.3.0-6.7.fc8

How reproducible:
it happen usually if i use the italic before to press the return key. 

Steps to Reproduce:
1.open writer
2.select the italic format (CTRL+I)
3.write something
4.now you can remove the italic format, but if you want to use it again you
can't anymore..
  
Actual results:


Expected results:


Additional info:
sometimes it happen the opposite: you think it's ok but you can just remove
italic, and to give this format you've to select the text.. i.e. try:
1. make a list with the - sign,
2. write something not italic,
3. write the again, but italic,
4. write not italic,
now it's impossible to write italic again without selecting the target text.
Comment 1 Caolan McNamara 2008-01-18 09:02:33 EST
I don't understand your problem at all. Blank document, Ctrl+I I am in italic.
Ctrl+I I am not in italic. Ctrl+I I am in italic again. Ctrl+I. Gives as
expected, italic text, non-italic text, and the italic text again.
Comment 2 Jan Navratil 2008-01-18 09:05:05 EST
I've seen this odd italic formating as well. But it's hard to reproduce, because
it appears randomly (but quite often).
Comment 3 lm 2008-01-18 09:07:52 EST
when i start or finish a line (return key) with the italic format then it happen
that i can't change it again. 

try to write some lines, changing the format.
thanks 
Comment 4 Caolan McNamara 2008-01-18 09:18:29 EST
Still baffled, I don't see this nor ever had the problem myself. Is there a
guaranteed exact set of steps to make it happen.
Comment 5 lm 2008-01-18 09:30:23 EST
i just reproduced it. here there are the steps..

1. open OOoWriter,
2. [CTRL+I] (write something) in italic 
3. [CTRL+I] *to write the next in normal*
4. [RETURN]
4. (write something) in normal
5. [CTRL+I] now it has no effect..

and more:
6. [RETURN]
7. [CTRL+I] now it has its own effect, but just to the next normal..

Comment 6 lm 2008-01-18 09:33:00 EST
i just reproduced it. here there are the steps..

1. open OOoWriter,
2. [CTRL+I] (write something) in italic 
3. [CTRL+I] *to write the next in normal*
4. [RETURN]
4. (write something) in normal
5. [CTRL+I] now it has no effect..

and more:
6. [RETURN]
7. [CTRL+I] now it has its own effect, but just to the next normal..

Comment 7 Caolan McNamara 2008-01-18 09:42:39 EST
indeed, I see it with that example in F8, strangely not with to-be-F9 in 2.4.0
so it's like known and fixed, if I can find it I'll stick it into an F8 update
Comment 8 Caolan McNamara 2008-01-18 10:02:42 EST
Will be in >= 2.3.0-6.12
Comment 9 Fedora Update System 2008-03-20 04:07:31 EDT
openoffice.org-2.3.0-6.12.fc8 has been submitted as an update for Fedora 8
Comment 10 Fedora Update System 2008-03-21 18:01:57 EDT
openoffice.org-2.3.0-6.12.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2552
Comment 11 Gian Paolo Mureddu 2008-03-25 01:58:03 EDT
I can confirm that this bug is reproducible not only with italics, but also bold
and underscore font styles too. Will install the version in updates-testing and
report appropriately.
Comment 12 Fedora Update System 2008-04-08 14:40:57 EDT
openoffice.org-2.3.0-6.13.fc8 has been submitted as an update for Fedora 8
Comment 13 lm 2008-04-10 11:50:39 EDT
i can't find OpenOffice.org-2.3.0-6.13.fc8 as update for Fedora8.

the latest one i can download is OpenOffice.org-2.3.0-6.11.fc8..
Comment 14 Fedora Update System 2008-04-17 14:38:42 EDT
openoffice.org-2.3.0-6.14.fc8 has been submitted as an update for Fedora 8
Comment 15 lm 2008-04-18 01:50:34 EDT
well i read it yet in the #12, by the way, when i search for updates, it say
that the system is up to date. 

maybe i haven't the right repository?

thanks for patience.
Comment 16 Fedora Update System 2008-04-22 18:40:55 EDT
openoffice.org-2.3.0-6.14.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Yolkfull Chow 2008-06-25 22:44:17 EDT
Verified the three text format with version
openoffice.org-writer-2.4.1-17.4.fc9.i386, CTRL+I (italic), CTRL+B (bold),
CTRL+U (underscore) work fine.

Note You need to log in before you can comment on or make changes to this bug.