Bug 429298 - Asking for global address list server password when global catalogue server is not set
Asking for global address list server password when global catalogue server i...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-exchange (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 11:10 EST by Jonathan Underwood
Modified: 2008-03-11 23:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 23:15:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 521913 None None None Never

  None (edit)
Description Jonathan Underwood 2008-01-18 11:10:48 EST
Description of problem:
I have an email account set up using the exchange connector, but I don't have
anything entered into the global catalogue server name box, since the GAL server
isn't accessible from off-site (although the OWA server is). Nonetheless, when 
composing a message, it asks for a global address list password, which is pointless.

Also, I have another account set up to access an imap server. When I compose a
message using that account, it still asks for a global address list password,
which is even more bizarre.

Version-Release number of selected component (if applicable):
evolution-2.12.2-3.fc8
evolution-data-server-1.12.2-1.fc8
evolution-webcal-2.12.0-1.fc8
evolution-data-server-1.12.2-1.fc8
evolution-2.12.2-3.fc8
evolution-exchange-2.12.2-1.fc8

How reproducible:


Steps to Reproduce:
1.Set up two accounts in evolution - one to access an imap account, the other to
access a MS outlook web access account but with nothing set for the global
catalogue server
2.Compose a message using either identity
3.
  
Actual results:
As above - asks for a global address list passwd.

Expected results:
Should not be trying to access a global address list if global catalogue server
is not set.

Should not be trying to access a global addres list when using an imap  account

Additional info:
Comment 1 Jonathan Underwood 2008-01-18 12:52:32 EST
Um, ok, perhaps this is not so much of a bug but rather a badly designed feature
of the gui - of course the problem goes away completely if I unselect the GAL in
the "Autocompletion" tab of the Preferences dialogue. Having that enable itself
by default even when no GAL server is specified is... dumb. 

In any case, it should be a per account option, not a global option - i.e. there
should be an autocomplete tab for each account. If I did have a GAL server set
for the exchange account, I would want it to query there when using the exchange
account but not when using the other IMAP account.
Comment 2 Matthew Barnes 2008-03-11 23:15:09 EDT
Moving this upstream.  Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=521913

Note You need to log in before you can comment on or make changes to this bug.