Bug 429365 - Fedora 8 fails to boot after various methods of install.
Fedora 8 fails to boot after various methods of install.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 16:54 EST by Chris Schembari
Modified: 2009-01-09 00:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:48:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from dmesg while running the F8 Live CD on the same machine. (19.72 KB, text/plain)
2008-01-18 16:54 EST, Chris Schembari
no flags Details

  None (edit)
Description Chris Schembari 2008-01-18 16:54:37 EST
Description of problem: NOTE: Choice of kudzu above is just a wild guess, as
this is a booting problem and kudzu is the only program on the list that runs at
boot and that I've at least heard of.
  Fedora 8 does not boot up correctly after a fresh install, on a computer that
both before and since has had no problem booting up Fedora 7.  I first tried the
Fedora-8-i386-DVD iso (3.2 GB) with a 12MB USB bootdisk.img file, and also the
Fedora-8-KDE-i686 Live CD. Both seem to work as expected in installing
everything, but I run into the same problem with both: the reboot afterward in
either case stalls just before you would expect the "Welcome to Fedora" message.

Machine specs: AthlonXP 2400+ with 512MB DDR-333 RAM (64MB shared) on an Abit
VA-10 motherboard, VIA UniChrome KM400 onboard graphics chipset
sda: Seagate 160GB ATA-100 HDD
sda1 Windows XP SP2 (32GB)
sda2 DesktopBSD 1.6rc3 (32GB)
sda3 Fedora's /boot (196MB)
sda4 extended partition, remainder of drive, filled with sda5 as LVM PV
sdb: Western Digital 80GB ATA-100 HDD (unused by Linux)
sdb1 32GB FAT32, my data "lifeboat"; remainder of HDD is free space

This machine has worked well with both FC6 and F7. After repeated attempts to
get F8 up and running, I reinstalled F7 from my KDE live CD and am typing this
up within F7. Note that having DBSD in a triple-boot configuration with WinXP
and Linux does not seem to trouble F7 at all, so I don't think the problem is there.

When using the stock LVM configuration, I get the following boot screen:
************************************************************************
Booting 'Fedora (2.6.23.1-42.fc8)'
root (hd0,2)
Filesystem type is ext2fs , partition type 0x83
kernel /vmlinuz-2.6.23.1-42.fc8 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
[Linux-bzImage , setup=0x2c00, size=0x1e0320]
initrd /initrd-2.6.23.1-42.fc8.img
[Linux-initrd @ 0x1bc62000, 0x37d947 bytes]
Uncompressing Linux... Ok, booting the kernel.
************************	[Long delay here, maybe 10 - 20 seconds.]
Red Hat nash version 6.0.19 starting
Reading all physical volumes. This may take a while...
Found volume group "VolGroup00" using metadata type lvm2
2 logical volume(s) in volume group "VolGroup00" now active
__ 	<--- blinking cursor. At this point it just hangs and won't go any further.
After half an hour or so, the CRT powers off on its own, but I usually reboot
before then. The message "Welcome to Fedora" never shows up (like it does in
Fedora 7 and before).

When I tried using ext3 partitions instead, to see if LVM was at fault, it was
pretty much the same, apart from the hexadecimal numbers being different, and
except that it would stop three lines sooner, immediately after the "nash
6.0.19" message above.


Version-Release number of selected component (if applicable): Fedora 8 (both
i386 DVD iso and i686 LiveCD.


How reproducible: Every time.


Steps to Reproduce:
1. Boot to either install method and run installer, following instructions and
choosing options for typical multi-boot install.
2. Reboot and remove install media in the process.
3. Watch helplessly as machine hangs.
  
Actual results: See above.

Expected results: An awesome F8 install!

Additional info: I've attached a text file, the output from dmesg while running
the F8 i686 Live CD.
Comment 1 Chris Schembari 2008-01-18 16:54:37 EST
Created attachment 292215 [details]
Output from dmesg while running the F8 Live CD on the same machine.
Comment 2 Chris Schembari 2008-02-13 17:15:52 EST
UPDATE: I ran sha1sum on the F8-KDE-LiveCD.iso file and confirmed that it
matched the sha1sum on the Fedora mirror I downloaded it from. When I burned
that LiveCD to disc, I used K3B's "verify data" option, so I already knew it was
a good burn.
I also successfully installed F8 on my old computer* using the same LiveCD that
I used for the above abortive install. That computer boots just fine into and
runs Fedora, despite being a much lower-spec system. There is one error when F8
boots on that PC, though. Right before the "Red Hat nash" comment, I see a
message saying "Invalid PBLK length [5]". Like I wrote, it doesn't stop the boot
process.

* Machine specs for my old computer:
HP Pavilion 6735-kr, with a P-III 850MHz (Upgraded by me from the stock Celeron
CPU) on a TriGem Cognac motherboard with 384MB pc100 sdram and an Intel 82810
graphics/memory controller hub chipset.
http://h10025.www1.hp.com/ewfrf/wc/product?product=59857&lc=en&cc=us&dlc=en&lang=en&cc=us
Comment 3 Chris Schembari 2008-07-31 13:25:00 EDT
UPDATE:  I have since then installed Fedora 9 via Live CD (both GNOME and KDE)
on a flash drive using the Fedora livecd-tools package from within F7.  F9
installs and runs successfully after reboot, but I've had repeated
package-installation problems with PackageKit (MD5 checksums errors on /every/
package install attempted within F9!), so I eventually nuked F9 and tried F8
again.  Same Live CD produces the same problem as before (LONG delays in
loading/uncompressing kernel, stall right after "nash" comment).  Note that the
local mirror I used has an F8 KDE ISO (
http://mirror.anl.gov/pub/fedora/linux/releases/8/Live/i686/Fedora-8-Live-KDE-i686.iso
) which was last modified on 2007-11-02.

Then finally SUCCESS!  I KTorrented the F8 XFCE custom spin, dated 2008-02-12,
from http://torrent.fedoraproject.org/torrents//Fedora-8-Live-XFCE-i686.torrent
, and used the same livecd-tools package to put it on the same 1GB USB flash
drive as I used before.  It worked! The system rebooted successfully, and I'm
now using XFCE to download and install the F8 KDE and assorted other packages.

So the bug lies in one or more packages on the KDE live CD ISO and was corrected
at some point before the building of the XFCE spin ISO.  That ought to make it
easier to spot!
Comment 4 Chris Schembari 2008-07-31 13:29:34 EDT
... or I suppose the bug could be in package(s) in the KDE CD but not included
in the XFCE CD, too.
Comment 5 Chris Schembari 2008-09-20 13:08:45 EDT
  I think I figured out where this problem is coming from, and that it really does have to do with installing F8 as a dual- or multi-boot system that already has some flavor of BSD installed on it.

  I tried to re-install F8 (both x86 and x86_64) on another homebuilt box of mine (an AMD64 Sempron) that had had no problems with F8 beforehand. F8 was a stand-alone OS on that box before, but this time I wanted to also try dual-booting PC-BSD 1.5.1 and F8 together for comparison. I found that suddenly F8 no longer worked but showed the same problem as above: it would start to boot but hang up right after the “nash” message. However, as before, I could install F7 or the F8 XFCE re-spin dated 2008-02-12 and either one worked fine.

  I also noticed something else with this particular system. After I installed it next to PC-BSD, F7 assigned a different label to its own “/” directory in grub's boot arguments, which shows “root=LABEL=/1 rhgb quiet”. Filesystem checks during boot also ID the root partition as "/1" instead of "/".  Maybe the live CD installer program sees the BSD “/” partition and tries to avoid confusion between this and the Fedora “/” partition by assigning the “/1” custom label and/or making some other change, a change that F7 and the F8 XFCE re-spin handle well but not the initial release of F8 dated 2007-11-02?

  This other homebrew box has a 64-bit Sempron CPU, 2GB DDR2 SDRAM, an ECS GeForce motherboard (don't have the model name to refer to here), and NVidia graphics and media controller chips.
Comment 6 Chris Schembari 2008-09-20 13:09:39 EDT
(In reply to comment #4)
> ... or I suppose the bug could be in package(s) in the KDE CD but not included
> in the XFCE CD, too.

UPDATE ON THE ABOVE:  With the XFCE respin on the above Soyo/Abit PC I mentioned on 2008-07-31, I was able to install, switch over to, and use KDE as my default desktop without problem.
Comment 7 Bug Zapper 2008-11-26 04:28:42 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2009-01-09 00:48:38 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.