Bug 429375 - (CVE-2008-0364) CVE-2008-0364 Bittorent uses wcscpy() unsafely
CVE-2008-0364 Bittorent uses wcscpy() unsafely
Status: CLOSED NOTABUG
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
http://nvd.nist.gov/nvd.cfm?cvename=C...
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 18:02 EST by Lubomir Kundrak
Modified: 2008-01-18 18:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 18:04:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2008-01-18 18:02:17 EST
Common Vulnerabilities and Exposures assigned an identifier CVE-2008-0364 to the following vulnerability:

Buffer overflow in (1) BitTorrent 6.0 and earlier; and (2) uTorrent
1.7.5 and earlier, and 1.8-alpha-7834 and earlier in the 1.8.x series;
on Windows allows remote attackers to cause a denial of service
(application crash) via a long Unicode string representing a client
version identifier.

References:

http://aluigi.altervista.org/adv/ruttorrent-adv.txt
Comment 1 Lubomir Kundrak 2008-01-18 18:04:41 EST
This seems to be Windows-only. The exploit code does nothing to our bittorrent,
it is written in python and never calls wcscpy().

Note You need to log in before you can comment on or make changes to this bug.