Bug 429380 - opensync plugin is in the wrong place on x86_64 systems
opensync plugin is in the wrong place on x86_64 systems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: synce-sync-engine (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 19:01 EST by Tom Hughes
Modified: 2008-01-25 11:56 EST (History)
0 users

See Also:
Fixed In Version: 0.11-6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-25 11:56:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Hughes 2008-01-18 19:01:13 EST
Description of problem:

The opensync plugin provided by synce-sync-plugin is in the
/usr/lib/opensync/python-plugins directory, but on x86_64 systems opensync
expects it to be in /usr/lib64/opensync/python-plugins.

Version-Release number of selected component (if applicable):

synce-sync-engine-0.11-3.fc8.noarch

Additional info:

Given that this is a noarch package it isn't obvious how to solve this, or even
if opensync is right to be looking for python plugins in lib64 rather than lib
given that they aren't architecture specific (or is the .pyc architecture
specific?).

Possibly this is actually a libopensync-plugin-python problem in that it should
be looking in lib not lib64?
Comment 1 Andreas Bierfert 2008-01-18 21:31:38 EST
Thanks for reporting this bug. I know the problem and I did play around with a
patched spec here the whole day. The new version of libopensync that is in devel
(0.35) actually puts this stuff into /usr/lib so there the package being noarch
is no problem. Since in my tests yum did not have anything against mixed
noarch/arch upgrades I will build as regular package in F8 and noarch in devel.
Comment 2 Andreas Bierfert 2008-01-25 11:56:48 EST
This has been fixed with the latest package in updates-testing.

Note You need to log in before you can comment on or make changes to this bug.