Bug 429420 - winepath -w output is "broken"
winepath -w output is "broken"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-19 12:05 EST by Davide Repetto
Modified: 2008-02-02 03:58 EST (History)
0 users

See Also:
Fixed In Version: 0.9.54-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-01 20:20:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Repetto 2008-01-19 12:05:10 EST
From Bugzilla Helper:
User-Agent: Opera/9.50 (X11; Linux i686; U; en)

Description of problem:
"winepath -w [path]" ouput is erroneously prepended by "Running padsp as 
pulseaudio wrapper for wine".

The cause is an "echo" statement in "/usr/bin/wine" (at line 4) which reads:

  echo "Running padsp as pulseaudio wrapper for wine"

The bug affect any script which depend on "winepath".

Version-Release number of selected component (if applicable):
wine-0.9.52-2.fc8

How reproducible:
Always


Steps to Reproduce:
1. winepath -w [/some/path]
2. look at the output


Actual Results:
Running padsp as pulseaudio wrapper for winez:\some\path


Expected Results:
z:\some\path

Additional info:
remove the "echo" statement from /usr/bin/wine end the problem is fixed. :)
Comment 1 Fedora Update System 2008-01-27 02:19:41 EST
wine-0.9.54-1.fc8, wine-docs-0.9.54-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine wine-docs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/F8/FEDORA-2008-1066
Comment 2 Fedora Update System 2008-02-01 20:20:02 EST
wine-docs-0.9.54-1.fc7, wine-0.9.54-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Fedora Update System 2008-02-02 03:58:45 EST
wine-0.9.54-1.fc8, wine-docs-0.9.54-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.