Bug 429458 - TurboGears 1.0.4 stable released
TurboGears 1.0.4 stable released
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: TurboGears (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-20 10:51 EST by Jan ONDREJ
Modified: 2016-09-19 22:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0.4.2-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 22:19:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2008-01-20 10:51:59 EST
Description of problem:
TurboGears 1.0.4 has been released. It fixes many of bugs and improves usability
with SQLAlchemy>0.4. Also SQLAlchemy 0.3 has many bugs, which are still not
solved in the 0.3 branch and are solved in 0.4.

Please, release an update of TurboGears at least for Fedora 8.
TurboGears in Fedora 8 is not fully usable, because som components are using
SQLAlchemy 0.3 and some 0.4.
For example there is this bug. which can be fixed:

How reproducible:
always

Steps to Reproduce:
1. tg-admin quickstart -s -i -p test1 test1
2. cd test1
3. tg-admin shell
  
Actual results:
Traceback (most recent call last):
  File "/usr/bin/tg-admin", line 8, in <module>
    load_entry_point('TurboGears==1.0.3.2', 'console_scripts', 'tg-admin')()
  File "/usr/lib/python2.5/site-packages/turbogears/command/base.py", line 389,
in main
    command.run()
  File "/usr/lib/python2.5/site-packages/turbogears/command/base.py", line 187,
in run
    mod = get_model()
  File "/usr/lib/python2.5/site-packages/turbogears/util.py", line 131, in get_model
    package = __import__(package_name, {}, {}, ["model"])
  File "/tmp/test1/test1/model.py", line 132, in <module>
    assign(Visit, visits_table)
  File "/tmp/test1/test1/model.py", line 130, in assign
    return assign_mapper(session.context, *args, **kw)
AttributeError: 'ScopedSession' object has no attribute 'context'

Expected results:
tg-admin shell prompt.

Additional info:
Thank you. :)
Comment 1 Luke Macken 2008-01-25 11:11:24 EST
TurboGears-1.0.4.2 has been built in devel.  
Comment 2 Jan ONDREJ 2008-01-25 16:09:41 EST
Thank you.

Can you build it for Fedora 8 too?
Comment 3 Luke Macken 2008-01-25 17:17:46 EST
Yep, I plan on it, which is why I left this bug open :)
Comment 4 Fedora Update System 2008-01-29 00:13:47 EST
TurboGears-1.0.4.2-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update TurboGears'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1107
Comment 5 Jan ONDREJ 2008-02-01 01:17:47 EST
Although it is a small change and there are no strict require for this, there is
a new TurboGears again. If you want, you can recompile package before stable
release:

1.0.4.3 is a minor improvement release to fix glitches in JavaScript issues and
improve the overall usability of the 1.0.x branch. 

I don't see problems in 1.0.4.2-3.fc8 package yet.
Comment 6 Luke Macken 2008-02-01 12:04:13 EST
1.0.4.3 built for rawhide.  Thanks for the heads up.
Comment 7 Jan ONDREJ 2008-02-17 01:43:09 EST
TurboGears-1.0.4.2-3.fc8 works for me. Can you put this to stable or build
1.0.4.3 for F-8?
Comment 8 Fedora Update System 2008-02-18 22:19:48 EST
TurboGears-1.0.4.2-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.