Bug 429471 - Print job doesn't finish using airport express print server.
Print job doesn't finish using airport express print server.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2008-01-20 16:05 EST by Simon Goodall
Modified: 2008-01-29 00:14 EST (History)
0 users

See Also:
Fixed In Version: 2.7.12-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 00:14:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
tcpdump output of print job (1.06 MB, application/octet-stream)
2008-01-21 15:16 EST, Simon Goodall
no flags Details

  None (edit)
Description Simon Goodall 2008-01-20 16:05:17 EST
Description of problem:
I have a HP photosmart 7960 connected via usb to an apple airport express. The
airport express advertises the printer over a jet direct port (9100).

When printing the test page it mostly prints out then stops. The printer still
says "printing". Cancelling the print tests and starting a new test page causes
the remaining section of the first job to start printing, followed by the second
job.
It appears as if the last part of the job is never sent or flushed from the
buffer until the next job starts.

The printer works fine when connected directly via usb.

Version-Release number of selected component (if applicable):
cups-1.3.4-4.fc8

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2008-01-21 05:02:21 EST
What does 'lpstat -s' say when the printer is connected via the airport express
print server?

I'd like to see the TCP/IP stream between the CUPS client and the print server
when a job is submitted.  You can do this by running this command:

tcpdump -s0 -U -w 9100.pcap port 9100

as root before sending the job, and pressing Control-C after the job has
finished printing as much as it's going to.  Attach the 9100.pcap file to this
bug report.  Thanks.
Comment 2 Simon Goodall 2008-01-21 15:16:31 EST
Created attachment 292406 [details]
tcpdump output of print job

lpstat -s shows the listed device uris with the relevant line being;

device for PhotoSmart_7960: socket://one.home:9100

where one.home is the hostname for my airport express.

See the attachment for the tcpdump output.
Comment 4 Tim Waugh 2008-01-25 07:19:37 EST
Possibly a duplicate of bug #428536.
Comment 5 Fedora Update System 2008-01-27 02:11:21 EST
hplip-2.7.12-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/F8/FEDORA-2008-0820
Comment 6 Simon Goodall 2008-01-27 08:14:20 EST
The update works. The supplied link gives me a 404 error.
Comment 7 Fedora Update System 2008-01-29 00:14:08 EST
hplip-2.7.12-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.