Bug 429479 - snake-server has broken deps in epel5 testing
snake-server has broken deps in epel5 testing
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: snake (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: James Laska
Fedora Extras Quality Assurance
:
Depends On:
Blocks: EPEL5-BrokenDeps
  Show dependency treegraph
 
Reported: 2008-01-20 16:53 EST by Kevin Fenzi
Modified: 2013-09-02 02:23 EDT (History)
4 users (show)

See Also:
Fixed In Version: snake-0.10-0.4git
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-28 08:49:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2008-01-20 16:53:22 EST
package: snake-server - 0.9-0.5git.el5.noarch from epel-testing
  unresolved deps: 
     pykickstart >= 0:1.1

pykickstart-0.43 seems to be the one available in RHEL5. 
Can this version of snake be made to work with that? 
Or could an update be requested of the package in RHEL5?
Comment 1 James Laska 2008-01-21 08:28:20 EST
The snake base package (client) is intended for any distro release ... while the
snake-server package requires pykickstart >= 1.1.

To resolve the deps I can:
 1. Drop the version requirement and add a note into the README that execution
will require an updated pykickstart
 2. We backport the pykickstart changes into RHEL5
 3. We backport the pykickstart changes into EPEL5 (I think this goes against
EPEL policy)
 4. Special case the .spec file so that only the base snake package is built on
EPEL4 and EPEL5.

The least messy approach seems to be #1.  

#4 seems ideal but may not be appropriate in a spec file?

Any thoughts?
Comment 2 Jesse Keating 2008-01-21 09:21:28 EST
1 violates the rule of least surprise.  4 might be an option until 2 is
accomplished.
Comment 3 James Laska 2008-01-21 10:17:24 EST
clumens: What are your thoughts about option#2 ... I imagine that would be
rather difficult given it's a big version bump.
Comment 4 Chris Lumens 2008-01-21 10:47:34 EST
We can't put the latest pykickstart in RHEL5 without making significant changes
to anaconda and system-config-kickstart.  I'd rather not do that.
Comment 5 James Laska 2008-01-21 10:56:58 EST
Thanks Chris!  option#4 it is...
Comment 6 James Laska 2008-01-25 08:16:07 EST
Fixed in snake-0.10-0.4git.el5.  The snake-server sub-package will no longer be
built.

Detail for Job ID 38066 (snake):
--------------------------------------------------------------------------------
Source: snake-0_10-0_4git_el5
Target: fedora-5-epel
Submitter: jlaska@redhat.com
Status: needsign/
Archjobs:
    noarch: ppc2.fedora.redhat.com    done/done
Comment 7 James Laska 2008-01-25 08:20:23 EST
38066 (snake): Build on target fedora-5-epel succeeded.
     Build logs may be found at
http://buildsys.fedoraproject.org/logs/fedora-5-epel/38066-snake-0.10-0.4git.el5/
Comment 8 Kevin Fenzi 2008-01-25 14:57:28 EST
This build was just pushed out... shall we go ahead and close this now? 

Thanks for the prompt attention here. 
Comment 9 James Laska 2008-01-28 08:49:30 EST
This issue has been fixed in snake >= snake-0.10-0.4git

Note You need to log in before you can comment on or make changes to this bug.