Bug 429480 - translate-toolkit has broken deps in epel5 testing
translate-toolkit has broken deps in epel5 testing
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: translate-toolkit (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Roozbeh Pournader
Fedora Extras Quality Assurance
:
Depends On:
Blocks: EPEL5-BrokenDeps
  Show dependency treegraph
 
Reported: 2008-01-20 17:01 EST by Kevin Fenzi
Modified: 2008-12-10 08:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 08:46:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2008-01-20 17:01:10 EST
package: translate-toolkit - 0.10.1-1.el5.noarch from epel-testing
  unresolved deps: 
     python-enchant

Looks like python-enchant has a EL-5 branch, but just hasn't been built yet.
Comment 1 Roozbeh Pournader 2008-01-21 08:23:32 EST
Well, python-enchant needs enchant to build, which is not branched for EL-5.
That's the reason python-enchant is not built.
Comment 2 Kevin Fenzi 2008-01-23 18:45:57 EST
Ah, does enchant build ok on EL-5? Does the maintainer want to maintain it in
EPEL? Or would you be able to do that? 
Comment 3 Tony Fu 2008-09-09 23:10:22 EDT
requested by Jens Petersen (#27995)
Comment 4 Kevin Fenzi 2008-09-20 18:50:33 EDT
This broken dep is still there. There still is not a python-enchant package. 

Bug 27995 seems to have nothing to do with this.
Comment 5 Dwayne Bailey 2008-11-17 08:21:29 EST
(In reply to comment #1)
> Well, python-enchant needs enchant to build, which is not branched for EL-5.
> That's the reason python-enchant is not built.

It seems that enchant has been built but python-enchant remains unbuilt.

For now I've removed the dependency in translate-toolkit see:

http://cvs.fedoraproject.org/viewvc/rpms/translate-toolkit/EL-5/translate-
toolkit.spec?r1=1.12&r2=1.13

The consequence is that spell checking in the pofilter tests will not work. The Toolkit already handles a missing python-enchant, so no problems expected.

We can reenable python-enchant support when EL-5 packages get built.
Comment 6 Dwayne Bailey 2008-11-17 08:23:01 EST
New build without python-enchant completed on EL-5

http://buildsys.fedoraproject.org/build-status/job.psp?uid=773
Comment 7 Dwayne Bailey 2008-12-10 08:46:57 EST
Build has been released which doesn't need python-enchant

Note You need to log in before you can comment on or make changes to this bug.