Bug 429490 - Search makes FF 3 too wide, scrollbar lost
Search makes FF 3 too wide, scrollbar lost
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-20 22:13 EST by Pete Zaitcev
Modified: 2009-04-23 16:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 16:34:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of the problem (119.81 KB, image/png)
2008-01-20 22:13 EST, Pete Zaitcev
no flags Details
(Better) screenshot (120.07 KB, image/png)
2008-05-22 13:14 EDT, Pete Zaitcev
no flags Details
OK screenshot of upstream (90.44 KB, image/png)
2008-05-24 00:21 EDT, Pete Zaitcev
no flags Details

  None (edit)
Description Pete Zaitcev 2008-01-20 22:13:55 EST
Description of problem:

Vertical scrollbar disappears if search function is used, and several
tabs are present. Please see attached screenshot.

Version-Release number of selected component (if applicable):

firefox-3.0-0.beta2.11.nightly20080115.fc9

How reproducible:

100%, but you need to know how

Steps to Reproduce:
1. Run Firefox 3 in an unmaximized window
2. Open enough tabs so they get smaller than their natural size,
   but not enough for them to overflow and obtain the little
   extension button
3. Find a page with enough text for scrollbar to appear
   (e.g. a Bugzilla page)
4. Hit ^F, get search bar.
5. Search for any string that is present in the text, like "firefox"
6. Once you searched twice, the rendered pane will get wider, so
   the scrollbar disappears and cannot be clicked. The scroller mouse
   still works, so it's there, only invisible.
  
Actual results:

Scrollbar disappears, text wider than the screen.

Expected results:

Text width remaining as it was before the search.

Additional info:

To recover, you need to close search bar and the tabs.
Comment 1 Pete Zaitcev 2008-01-20 22:13:55 EST
Created attachment 292311 [details]
Screenshot of the problem
Comment 2 Matěj Cepl 2008-01-21 06:18:47 EST
Hmm, two points:

a) cannot reproduce here with
firefox-3.0-0.beta2.11.nightly20080115.fc9.x86_64

b) no matter, what I do I have always "the little extension button" present even
when tabs don't covert whole width of the window. Do you have some extensions
present which could be the issue?
Comment 3 Pete Zaitcev 2008-01-21 19:00:25 EST
Regarding (b) bo you mean the vertical button (which drops down a list) or the
horizontal one (which shifts tabs left and right)? The list button is always
present, but the shift button is not.

Of extensions, I have Flashblock.

I figured more of what happens. When the search wraps, a message appears in the
search bar that says "Reached top of page, continued from ..." (latter part
unreadable). That message is what overflows the window. I guess your window is
just not narrow enough for it to happen.
Comment 4 Christopher Aillon 2008-01-22 16:19:18 EST
I also can't reproduce.  Is this a problem still with the latest snapshots from
rawhide/koji?  If so, we should move it upstream since this is upstream's code
and it's still a pre-release.
Comment 5 Pete Zaitcev 2008-01-23 18:38:04 EST
Fixed in 3.0-0.beta2.12.nightly20080121.fc9.
Comment 6 Pete Zaitcev 2008-05-22 13:13:24 EDT
The bug reoccured in firefox-3.0-0.63.cvs20080516.fc10.x86_64.
Thought this was fixed upstream?
Comment 7 Pete Zaitcev 2008-05-22 13:14:23 EDT
Created attachment 306404 [details]
(Better) screenshot
Comment 8 Pete Zaitcev 2008-05-22 13:29:48 EDT
I filed an upstream bug:
 https://bugzilla.mozilla.org/show_bug.cgi?id=435231
Comment 9 Pete Zaitcev 2008-05-24 00:18:03 EDT
Mozilla people made me to test their build, and surprise: it works.
This bug is specific to Fedora.

This is confusing a bit. Apparently a bug just like this existed
in upstream Firefox. _Probably_ that was what I reported originally
in this bug report. Then they fixed it, so I closed this. But now we
made a bug with exactly the same symptom.
Comment 10 Pete Zaitcev 2008-05-24 00:21:12 EDT
Created attachment 306559 [details]
OK screenshot of upstream

BTW... Upstream is UGLY in capital letters. I'd rather use our build,
if it worked.
Comment 11 Martin Stransky 2008-10-29 08:07:04 EDT
Taking this bug...
Comment 12 Bug Zapper 2008-11-25 21:05:05 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Pete Zaitcev 2009-04-23 16:34:06 EDT
This seems fixed in 3.1 Beta 3 (available in F11 Beta). Closing.

Note You need to log in before you can comment on or make changes to this bug.