Bug 429491 - use option "-m[M]-module" when module is not specified, error message should be outputted in phase 'option analysis'
use option "-m[M]-module" when module is not specified, error message should ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perl (Show other bugs)
5.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Marcela Mašláňová
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-20 23:13 EST by Yu Zhiguo
Modified: 2010-01-12 04:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 493355 554645 (view as bug list)
Environment:
Last Closed: 2009-01-20 16:11:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch to correct this problem (541 bytes, patch)
2008-01-20 23:13 EST, Yu Zhiguo
no flags Details | Diff

  None (edit)
Description Yu Zhiguo 2008-01-20 23:13:10 EST
Description of problem:
  Use command perl with option "-m-module" or "-M-module" when module is not 
specified or specified '', error message should be outputted in phase 'option 
analysis' rather than 'compilation'.
(like using these option without a dash("-"))

Version-Release number of selected component (if applicable):
  perl-5.8.8-10

How reproducible:
  100%

Steps to Reproduce:
  # perl -m- -e 'print 123'
  or
  # perl -m-'' -e 'print 123'
  
Actual results:
  error message is outputted in phase 'compilation':

  syntax error at -e line 0, near "no ;"
  Execution of -e aborted due to compilation errors.

Expected results:
  error message should be outputted in phase 'option analysis' like using 
option -m[M] without a dash ("-"):

  # perl -m -e 'print 123'
  error message is:
  Missing argument to -m.

Additional info:
Comment 1 Yu Zhiguo 2008-01-20 23:13:10 EST
Created attachment 292312 [details]
the patch to correct this problem
Comment 2 RHEL Product and Program Management 2008-06-02 16:23:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2009-01-20 16:11:16 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0117.html

Note You need to log in before you can comment on or make changes to this bug.