Bug 429500 - x startup fails, no fallback offered
x startup fails, no fallback offered
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 01:39 EST by James G. Sack
Modified: 2013-01-09 23:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:36:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf from F8 LiveCD failed boot attempt (581 bytes, application/octet-stream)
2008-01-21 21:04 EST, James G. Sack
no flags Details
Xorg.0.log from failed F8 LiveCD boot (17.97 KB, text/plain)
2008-01-21 21:05 EST, James G. Sack
no flags Details

  None (edit)
Description James G. Sack 2008-01-21 01:39:49 EST
From Bugzilla Helper:
User-Agent: Opera/9.25 (X11; Linux x86_64; U; en)

Description of problem:
Live CD on ECS 945GCT-M/1333 Motherboard using Intel GMA950 video chipset (AKA G945, 
I believe).

Live CD fails to start X, drops back to login screen.

Fix: adding
  xdriver=i810
to the boot kernel options works, and then allows install.

- - -
After install, get same problem. 

Fix: change
  Device="intel"
to
  Device="i810"
works.

..jim

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Boot Live CD (standard or KDE) on G945 video system
2. watch X fail to start.
3.

Actual Results:
I swore a little.

Expected Results:
Fallback to manual config allowing choosing video driver (and monitor specs) would be 
nice.

Additional info:
Strangely, the F7 Live CD works.
Ubuntu7.04 also fails but offers manual config that works (after guessing i810).
Medium severity but very bad publicity.
Comment 1 Matěj Cepl 2008-01-21 10:08:11 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 James G. Sack 2008-01-21 21:04:21 EST
Created attachment 292434 [details]
xorg.conf from F8 LiveCD failed boot attempt

note: Driver="intel"

seems like it should be Driver="i810"
 (at least, it works if it is i810)

..j
Comment 3 James G. Sack 2008-01-21 21:05:31 EST
Created attachment 292435 [details]
Xorg.0.log from failed F8 LiveCD boot

problem is with the card driver. Intel does not work (i810 does)
..j
Comment 4 James G. Sack 2008-01-21 21:06:11 EST
Booting F8 LiveCD (standard) flashes login couple of times then brings up a Curses 
dialog 
"""
Failed to stat the X server..view X server output..
"""
Y .. N

Pressing Y shows top 20 lines of xorg.0.log (I believe), and has no scroll 
provision. It has an OK button

After that comes a second dialog offering to view the detailed X server output.
which seems to show exactly the same screen of not-so-useful info.


Then a third dialog offering "..try to configure..". Choosing Y brings (either a 
quick flash or a pause at a login message (not repeatable), but then immediatly 
proceeds to "Trying to restart the X server" dialog awaiting an OK.

After the OK, it repeats as upon boot, as above.

---

If I hit Alt-F1 and answer root to the login prompt, I get a root prompt.

viewing /etc/X11/xorg.conf (a 30-line file) includes:
"""
Section "Device"
  Identifier "Videocard0"
  Driver "intel"
EndSection

There's other stuff that may be of interest in the following files
  /etc/X11/xorg.conf 
  /var/log/Xorg.0.log. 
which I attach
- - -

I mentioned before that xdriver=i810 fixes the boot problem.
Editing xorg.conf and changing Driver "intel" to Driver "i810" also works, as going 
back to console 7 (Alt-F7) to continue lets the "Trying to restart X" actually 
work.

..jim
Comment 5 James G. Sack 2008-01-22 01:20:06 EST
More info of possible use (from lspci):
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics 
Controller (rev 02) (prog-if 00 [VGA])
        Subsystem: Elitegroup Computer Systems Unknown device 2624
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fea80000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at dc00 [size=8]
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Memory at fea40000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 
Enable-
        Capabilities: [d0] Power Management version 2

I have no expertise but it seems to me that some docs imply that 945G is supposed 
to be supported in the (newer) intel xorg driver, which maybe supercedes/extends 
i810?

Regards,
..jim
Comment 6 Adam Jackson 2008-02-11 15:37:50 EST
Strange indeed.  Looks like it's just not finding modes on any pipe and
therefore refusing to start; it should at least struggle up to 800x600.  Can you
attach the log from i810 starting?  Would be good to see if there's a reason for
DDC to fail.
Comment 7 Bug Zapper 2008-11-26 04:30:26 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Mike C 2009-01-05 17:04:58 EST
Has this bug been tested in F10?  I have a machine with exactly this graphics chipset and I would like to know whether this bug is resolved at this stage?

F8 is going EOL very shortly - and if this bug is pertinent to F10 it should then remain open.
Comment 9 James G. Sack 2009-01-05 17:30:39 EST
I believe the bug _was_ present in the F10 release, but fixed in the first kernel upgrade.
Thanks, guys.
..jim
Comment 10 Mike C 2009-01-05 17:42:17 EST
I have a machine with 82845G and tried to install from a home-spun-respin  for F10 with all released updated packages today (with updates to 3rd January) and the graphical install failed to give a readable screen at the point the graphical window starts up (HD install).

I also have a machine with 82945G but have not dared to try and upgrade (as a clean install) in case it also fails which is why I am looking to these reports to find if there really is a solution. Since my install DVD iso has the newer kernel already in it I will try an install for the 82945G machine tomorrow to see if the install at least proceeds to the graphical part and gives me a readable screen.

Are you implying you have tested this for a real install for a 945 machine? That would give me some hope that an install on that machine might proceed and give a bootable system with running X.
Comment 11 Mike C 2009-01-05 17:59:30 EST
By the way it would be nice to have this bug either confirmed as currentrelease and closed, or remain open as an F10 bug rather than dropping off the radar due to F8 EOL.
Comment 12 Mike C 2009-01-06 07:57:51 EST
I have now tested an install on a Dimension 2400 which has the 82845G graphics chipset - the only way I could get a graphical install was to run (using my updated F10 DVD personal re-spin including updates to 3rd January 2009), and initiating the install from a grub stansa calling the iso from an HD install, and including the parameter "xdriver=vesa nomodeset" from the kernel boot line.

This allowed a graphical install and when it got to firstboot I intercepted the boot and entered the same parameter as above to the kernel line to initiate firstboot.

This worked and I can then boot the system with the same procedure to run as "normal" - however the graphics with the vesa driver are far from perfect, and the screen is fuzzy despite having 1280x1024 resolution set.

I have edited xorg.conf to include the vesa driver and it will boot although the text mode Plymouth boot line works apart from a brief interruption at an early stage when the screen blanks for a moment.

system-config-display is not installed by default and this may help a little if installed and used to reconfigure the display - but the basic problem is that the driver is buggy and needs fixing.
Comment 13 Bug Zapper 2009-01-09 02:36:33 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.