Bug 429508 - update vym
update vym
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: vym (Show other bugs)
el5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 03:36 EST by Marek Mahut
Modified: 2008-02-18 17:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 16:38:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file from opensuse (32.15 KB, text/x-rpm-spec)
2008-02-10 09:59 EST, Marek Mahut
no flags Details
Fix for vym build in RHEL-5 (21.27 KB, patch)
2008-02-18 14:24 EST, Lubomir Kundrak
no flags Details | Diff

  None (edit)
Description Marek Mahut 2008-01-21 03:36:09 EST
Is it possible to upgrade vym in EL5-testing to 1.10, please? Thank you!
Comment 1 Jon Ciesla 2008-01-21 08:56:47 EST
If RHEL-5 has QT4, then yes.  Does it?
Comment 2 Marek Mahut 2008-01-28 07:15:56 EST
(In reply to comment #1)
> If RHEL-5 has QT4, then yes.  Does it?

Ooops. Sorry I missed your reply from bugzilla.

I belive it does, information from RHN:

Package: qt4-devel-4.2.1-1.i386
Channel: Red Hat Enterprise Linux (v. 5 for 32-bit x86)
Comment 3 Jon Ciesla 2008-01-28 08:08:31 EST
Imported, build failed on ppc:
/var/tmp/rpm-tmp.67513: line 28: qmake-qt4: command not found

Full logs:
http://buildsys.fedoraproject.org/logs/fedora-5-epel/38086-vym-1.10.0-1.el5/

ExcludeArch?
Comment 4 Marek Mahut 2008-01-28 09:16:59 EST
Hm, looks like it has different name and location in el5.

[root@mmahut ~]# rpm -ql qt4-devel | grep make
/usr/lib/qt4/bin/qmake
...
[root@mmahut ~]#
Comment 5 Jon Ciesla 2008-01-28 09:42:30 EST
Tried that just now.

+ qmake DOCDIR=/usr/share/doc/vym-1.10.0 PREFIX=/usr
/var/tmp/rpm-tmp.98574: line 28: qmake: command not found
error: Bad exit status from /var/tmp/rpm-tmp.98574 (%build)

Path issue?  Might I have to do /usr/lib/qt4/bin/qmake instead of qmake?
Comment 6 Marek Mahut 2008-01-28 10:01:53 EST
Yop, use full patch or add /usr/lib/qt4/bin/ to PATH.

On RHEL5:

[root@mmahut ~]# /usr/lib/qt4/bin/qmake --version
QMake version 2.01a
Using Qt version 4.2.1 in /usr/lib/qt4/lib
[root@mmahut ~]# rpm -qf /usr/lib/qt4/bin/qmake 
qt4-devel-4.2.1-1
[root@mmahut ~]# whereis qmake
qmake:
[root@mmahut ~]# 
Comment 7 Jon Ciesla 2008-01-28 10:53:05 EST
Using full path failed.  Might it not be picking up the qt4 libs either?

ui_branchpropwindow.h:239: error: 'class QHBoxLayout' has no member named
'setBottomMargin'
make: *** [branchobj.o] Error 1
ui_historywindow.h: In member function 'void Ui_HistoryWindow::setupUi(QDialog*)':
ui_historywindow.h:42: error: 'class QGridLayout' has no member named
'setLeftMargin'
ui_historywindow.h:43: error: 'class QGridLayout' has no member named 'setTopMargin'
ui_historywindow.h:44: error: 'class QGridLayout' has no member named
'setRightMargin'
ui_historywindow.h:45: error: 'class QGridLayout' has no member named
'setBottomMargin'
ui_historywindow.h:46: error: 'class QGridLayout' has no member named
'setHorizontalSpacing'
ui_historywindow.h:47: error: 'class QGridLayout' has no member named
'setVerticalSpacing'
ui_historywindow.h:74: error: 'class QHBoxLayout' has no member named
'setLeftMargin'
ui_historywindow.h:75: error: 'class QHBoxLayout' has no member named 'setTopMargin'
ui_historywindow.h:76: error: 'class QHBoxLayout' has no member named
'setRightMargin'
ui_historywindow.h:77: error: 'class QHBoxLayout' has no member named
'setBottomMargin'
make: *** [exports.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.492 (%build)
Comment 8 Marek Mahut 2008-01-30 02:08:47 EST
Hm, yes maybe. I'm not sure. Please try to ask epel or devel-list.
Comment 9 Marek Mahut 2008-02-10 09:54:12 EST
Did you find the issue yet? Or it isn't a problem with qt4 libs path?
Comment 10 Marek Mahut 2008-02-10 09:59:21 EST
Created attachment 294497 [details]
spec file from opensuse

for inspiration
Comment 11 Lubomir Kundrak 2008-02-18 14:24:45 EST
Created attachment 295196 [details]
Fix for vym build in RHEL-5

This worked for me.
May I ask what's the reasoning behind not having cvsextras commits enabled?
Comment 12 Jon Ciesla 2008-02-18 15:11:41 EST
Made spec changes, added patch, build died.

Patch formatting issue?
http://buildsys.fedoraproject.org/logs/fedora-5-epel/38374-vym-1.10.0-1.el5.1/ppc/build.log

cvsextras now open.  Sorry for the oversight.
Comment 13 Lubomir Kundrak 2008-02-18 16:38:49 EST
Jon: Built fine this time. The patch, hmm... either of us was smoking something
bad :) Nevertheless, thanks for extras commits!
Comment 14 Jon Ciesla 2008-02-18 17:09:31 EST
Wow, I'd say.  Thanks for the assistance. :)

Note You need to log in before you can comment on or make changes to this bug.