Bug 429509 - Pungi misses .discinfo
Pungi misses .discinfo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 432505 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 03:39 EST by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 22:06:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2008-01-21 03:39:47 EST
Description of problem:


[root@gopher punk]# cat ks.cfg 
repo --name=fedora --baseurl=http://mirror.brq.redhat.com/fedora/8/i386/os/
repo --name=updates --baseurl=http://mirror.brq.redhat.com/fedora/updates/8/i386/
[root@gopher punk]#

(those are mirrors of respective repositories)

[root@gopher punk]# setarch i586 pungi --cachedir=/home/pungi -c ks.cfg
--nosource --destdir=$PWD/result
...
Pungi.Pungi:INFO: Running /usr/lib/anaconda-runtime/buildinstall --product
Fedora --version 20080121 --release "Fedora 20080121" --prodpath Packages
--bugurl http://bugzilla.redhat.com /home/lkundrak/punk/result/20080121/i386/os
Warning: creating filesystem that does not conform to ISO-9660.
Traceback (most recent call last):
  File "/usr/bin/pungi", line 188, in <module>
    main()
  File "/usr/bin/pungi", line 101, in main
    mypungi.doCreateIsos(split=opts.nosplitmedia)
  File "/usr/lib/python2.5/site-packages/pypungi/pungi.py", line 423, in
doCreateIsos
    self.doCreateSplitrepo()
  File "/usr/lib/python2.5/site-packages/pypungi/pungi.py", line 307, in
doCreateSplitrepo
    discinfo = open(os.path.join(self.topdir, '.discinfo'), 'r').readlines()
IOError: [Errno 2] No such file or directory:
'/home/lkundrak/punk/result/20080121/i386/os/.discinfo'
[root@gopher punk]#

Version-Release number of selected component (if applicable):

I believe everything is Fedora 8 with updates, happens also with Rawhide pungi.
Comment 1 timothy ball 2008-02-12 15:56:00 EST
I've experienced something similar, basically .discinfo doesn't get created.

--snip--snip--snip--
[root@clipper pungi]# pungi --version
pungi 1.1.10
[root@clipper pungi]# uname -a
Linux clipper.techprogress.org 2.6.23.1-42.fc8 #1 SMP Tue Oct 30 13:18:33 EDT
2007 x86_64 x86_64 x86_64 GNU/Linux
[root@clipper pungi]# cat /etc/fedora-release 
Fedora release 8 (Werewolf)
[root@clipper pungi]# setarch x86_64 pungi -c ./foo.ks --nosource --name=CAP
--ver=0.5
 ...
Pungi.Pungi:INFO: Linking release note file RPM-GPG-KEY-fedora-test
Pungi.Pungi:INFO: Linking release note file RPM-GPG-KEY-rawhide
Pungi.Pungi:INFO: Copying release note dir images
Pungi.Pungi:INFO: Copying release note dir stylesheet-images
Traceback (most recent call last):
  File "/usr/bin/pungi", line 178, in <module>
    main()
  File "/usr/bin/pungi", line 91, in main
    mypungi.doCreateSplitrepo()
  File "/usr/lib/python2.5/site-packages/pypungi/pungi.py", line 299, in
doCreateSplitrepo
    discinfo = open(os.path.join(self.topdir, '.discinfo'), 'r').readlines()
IOError: [Errno 2] No such file or directory: '/root/pungi/0.5/x86_64/os/.discinfo'

This is my foo.ks:
[root@clipper pungi]# cat foo.ks 
# Kickstart file automatically generated by anaconda.

repo --name=fedora-8
--mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-8&arch=x86_64

cmdline
cdrom
lang en_US.UTF-8
keyboard us
network --device eth1 --bootproto dhcp --hostname clipper.techprogress.org
rootpw  --iscrypted [redacted]
firewall --enabled --port=22:tcp
authconfig --enableshadow --enablemd5
selinux --enforcing
timezone --utc America/New_York
bootloader --location=mbr --driveorder=cciss/c0d0

%packages
@base
vim-enhanced
%end
Comment 2 Lubomir Kundrak 2008-02-12 16:27:21 EST
I'd close this. The problem in my case was that buildinstall or pungi whatever
was didn't contain much error handling so even though buildinstall failed and
exited before creating .buildinstall it just silently proceeded. I do not
remember what was the exact problem in my case, maybe it was shortage of disk
space or something like that.
Comment 3 Lubomir Kundrak 2008-02-12 16:47:07 EST
The problem both in your and in my case is that we ommited anaconda-runtime from
packages and that is required for the images to generate. Still the error
handling could be improved.
Comment 4 Jesse Keating 2008-02-28 16:32:06 EST
Yeah, I agree.  buildinstall happily returns 0 even though it failed crap, so
pungi doesn't catch it.  Not sure what I'm going to do about this.
Comment 5 Jesse Keating 2008-02-28 16:35:14 EST
*** Bug 432505 has been marked as a duplicate of this bug. ***
Comment 7 Jesse Keating 2008-07-15 22:06:19 EDT
Well, I've made it so that anaconda-runtime isn't necessary in the manifest,
since buildinstall now takes yum repos for input it can download what it needs.

Note You need to log in before you can comment on or make changes to this bug.