Bug 42951 - Network upgrade asks for file on 2nd CD while drive is locked
Network upgrade asks for file on 2nd CD while drive is locked
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-30 18:45 EDT by Ron Peterson
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-31 15:45:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ron Peterson 2001-05-30 18:45:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14-5.0 i686)

Description of problem:
While doing an upgrade from 6.2 to 7.1 using a network boot disk and
installing from an NFS mounted CD-ROM drive, the upgrade got through
about 3/4's of the upgrade and then produced this error message:
"The file /mnt/source/./RedHat/RPMS/emacs-20.7-34.i386.rpm cannot be
opened.  This is due to a missing file, a bad package, or bad media.  Press
<return> to try again."  Pressing the "ok" button (which is the
only option) brings up the same error message repeatedly.  Looking on the
RedHat CD's I see that the file in question is -not- on CD1 but is
instead located on CD2.  I tried unmounting the CD to put in the other
disk but I can't unmount (drive busy, even if I try forcing it) and
since the disk is spinning, the manual override for opening the tray
door is disabled.  Thus there's no way to change the CD and the
program is stuck in a loop.  I tried changing consoles to the
shell prompt and pressed return and it doesn't respond at all.
It appears to me that some rpm's were placed on the second CD
but the installer has no provisions for volume changes.  A work
around is probably to copy the CD's to disk.

How reproducible:
Didn't try yet

Steps to Reproduce:
1. Get hold of a RH6.2 system with emacs installed.
2. Start a network upgrade to 7.1 using an NFS mounted CD.
3. When the installer goes looking for emacs, see what happens.
	

Actual Results:  Installation is caught in a loop because it can't find the
file
because the file isn't there and there's no way to direct it to
where the file is (on the other CD).

Expected Results:  Instead of just presenting an "ok" button, entering a
path to
the file or allowing the remote CD drive to be temporarily unmounted
would be helpful.

Additional info:
Comment 1 Brent Fox 2001-05-31 15:45:40 EDT
You cannot do NFS installs that way.  With network installs, all the RPMs must
be in the same directory.  You need to copy the contents of CD1 and CD2 into a
directory on the NFS server and then export that directory.

Note You need to log in before you can comment on or make changes to this bug.