Bug 429512 - network initscript is not able to create bridge
network initscript is not able to create bridge
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 04:19 EST by Adam Tkac
Modified: 2014-03-16 23:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 04:54:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifcfg-eth0 configuration file (184 bytes, text/plain)
2008-01-21 04:19 EST, Adam Tkac
no flags Details
ifcfg-peth0 (131 bytes, text/plain)
2008-01-21 04:20 EST, Adam Tkac
no flags Details

  None (edit)
Description Adam Tkac 2008-01-21 04:19:05 EST
Description of problem:
I've got one network card and I have setup network bridge there. With latest
initscripts I'm not able to start it. Messages like "peth0 device doesn't
exists" will be seen.

Version-Release number of selected component (if applicable):
initscripts-8.61-1

How reproducible:
always

Steps to Reproduce:
See attached configuration
  
Actual results:
doesn't work

Expected results:
works fine

Additional info:
downgrade to initscripts-8.60-1 fixes problem for me
Comment 1 Adam Tkac 2008-01-21 04:19:52 EST
Created attachment 292345 [details]
ifcfg-eth0 configuration file
Comment 2 Adam Tkac 2008-01-21 04:20:17 EST
Created attachment 292346 [details]
ifcfg-peth0
Comment 3 Bill Nottingham 2008-01-21 13:16:04 EST
Interesting. There's nothing obvious in the changelog that would affect that.
Comment 4 Bill Nottingham 2008-01-21 13:21:01 EST
There's changes between 8.60 and 8.61 in both ifup-eth and ifdown-eth ; does
reverting either (or both) of these solve it?
Comment 5 Adam Tkac 2008-01-22 10:34:19 EST
This is pretty interesting problem. I've installed 8.61 and rebooted. Message
"Device peth0 does not seem to be present, delaying initialization." was printed
and network wasn't started. When I use ifup-eth from 8.60 (all other was from
8.61) network is started as expected. But when I downgraded to 8.60 and update
to 8.61 problem is not reproducable!. All steps written above was done without
reboot. When you reboot now you will see problem again. I'm not sure what's going on
Comment 6 Adam Tkac 2008-02-15 04:18:22 EST
Is known any workaround with initscripts >= 8.61-1? What is correct way to setup
bridge with newest initscripts?
Comment 7 Bill Nottingham 2008-02-15 14:34:01 EST
Hm, a test bridge worked for me fine. Is the ethernet device actually named
peth0 beforehand?
Comment 8 Adam Tkac 2008-02-18 04:54:58 EST
(In reply to comment #7)
> Hm, a test bridge worked for me fine. Is the ethernet device actually named
> peth0 beforehand?

Device was named eth0 so this was main problem. I'm not sure why such broken
configuration worked long time ago and now it causes problems. I fixed my
configuration and now it works as expected. Thanks for your hint, closing

Note You need to log in before you can comment on or make changes to this bug.