Bug 429548 - rpm doesn't depend on rpm-libs even links against it
rpm doesn't depend on rpm-libs even links against it
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rpm (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Panu Matilainen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 10:14 EST by Juha Tuomala
Modified: 2008-01-23 04:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 02:17:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juha Tuomala 2008-01-21 10:14:34 EST
Description of problem:

In centos4, rhel5:

tuju[0] rpm -q --requires rpm | grep librpmio
librpmio-4.3.so()(64bit)

tuju[0] rpm -q --whatprovides librpmio
no package provides librpmio

tuju[1] rpm -qf /usr/lib64/librpmio-4.3.so
rpm-libs-4.3.3-23_nonptl

tuju[0] ldd `which rpm`|grep rpmio
        librpmio-4.3.so => /usr/lib64/librpmio-4.3.so (0x000000344a900000)


So I guess rpm's deps are broken on these releases?

This is not the case in Fedora 8.
$ rpm -q --whatrequires "librpmio-4.4.so()(64bit)"
rpm-4.4.2.2-7.fc8
rpm-libs-4.4.2.2-7.fc8
rpm-python-4.4.2.2-7.fc8

Not really nasty unless you update with yum step by step and miss
that both got updated at the same time,but you only pull rpm. Most
likely it would work, but anyway, I think this shouldn't be like
this.
Comment 1 Juha Tuomala 2008-01-21 10:32:48 EST
Actually it looks like the postgresql and postgresql-libs suffer this same.

$ ldd `which psql `
        libpq.so.3 => /usr/lib64/libpq.so.3 (0x000000319b300000)

$ rpm -qf /usr/lib64/libpq.so.3
postgresql-libs-7.4.17-1.RHEL4.1
Comment 2 Panu Matilainen 2008-01-23 02:17:57 EST
> tuju[0] rpm -q --requires rpm | grep librpmio
> librpmio-4.3.so()(64bit)
  ^^^^^^^^^^^^^^^^^^^^^^^^

> tuju[0] rpm -q --whatprovides librpmio
> no package provides librpmio

Yup, no package provides "librpmio", you need to ask for the exact soname
dependency, ie

rpm -q --whatprovides "librpmio-4.3.so()(64bit)"

This is what you're doing in the Fedora case, only the other way around (via
requires), hence the difference.

[pmatilai@localhost ~]$ rpm -q --requires rpm | grep librpmio
librpmio-4.3.so  
[pmatilai@localhost ~]$ rpm -q --whatrequires librpmio-4.3.so
rpm-libs-4.3.3-23_nonptl
rpm-build-4.3.3-23_nonptl
rpm-4.3.3-23_nonptl
rpm-python-4.3.3-23_nonptl

No bug or broken dependencies here...
Comment 3 Juha Tuomala 2008-01-23 04:57:42 EST
Yep, you're right. Anyway, I came across this when updating:

# yum update rpm

and it didn't pull the rpm-libs on centos4. Perhaps that yum version didn't 
calculate the deps right there.

Note You need to log in before you can comment on or make changes to this bug.