Bug 429557 - add force flag to activation to force lowering entitlements
add force flag to activation to force lowering entitlements
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Pradeep Kilambi
Corey Welton
:
Depends On:
Blocks: 456998
  Show dependency treegraph
 
Reported: 2008-01-21 12:07 EST by Pradeep Kilambi
Modified: 2009-07-30 15:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 11:45:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2008-01-21 12:07:02 EST
Description of problem:
Need a new --force or a cfg option for activation to lower satellite
entitlements from new cert. This would clear up all the entitlements from the
non-base orgs and default the base-org to the cert.
Comment 1 Pradeep Kilambi 2008-01-23 13:11:23 EST
we'll reconsider this for sat-5.2.. no plan to add force flag now for activation
Comment 2 Brandon Perkins 2008-09-24 15:50:17 EDT
This needs to be re-reviewed for a valid use case for the implementation before starting work.  We don't want to do it just because we feel like its missing.  That is, we don't want to address a percieved issue and we want to know that it is in fact a real issue.
Comment 3 Pradeep Kilambi 2008-12-09 11:45:12 EST
Discussed with wes and we don't think this is a necessary change at this point. We can default this reset in ui the way we do it now by having the user flip the flag in rhn.conf. Its better we dont give such a destructive option through a simple command line flag. Another thing, this would not be in any event log if done from the backend.. so it ends up being untraceable in worst case scenario other than some log entries..

Closing this. Feel free to reopen if you have any other thoughts.

Note You need to log in before you can comment on or make changes to this bug.