Bug 429566 - GFS2: hang while creating file/directory
GFS2: hang while creating file/directory
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Robert Peterson
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 12:41 EST by Robert Peterson
Modified: 2009-05-27 23:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHEL5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-06 11:41:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upstream patch (547 bytes, patch)
2008-01-21 12:46 EST, Robert Peterson
no flags Details | Diff

  None (edit)
Description Robert Peterson 2008-01-21 12:41:39 EST
Description of problem:
I discovered this bug while browsing the code.  Function link_dinode
in inode.c of GFS2 has an incorrect error path.  If an error is
returned by function gfs2_diradd_alloc_required, the code will take
the wrong error patch and forget to unlock the quota file.
Subsequent similar operations will hang because the quota file is
locked and never unlocked.

Version-Release number of selected component (if applicable):
RHEL5.2

How reproducible:
Unknown

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Hang

Expected results:
No hang

Additional info:
I already submitted the fix for this upstream, and it's been accepted.
Comment 1 Robert Peterson 2008-01-21 12:46:21 EST
Created attachment 292390 [details]
Upstream patch

This is the upstream version of the patch.
Comment 2 Robert Peterson 2008-01-21 12:56:57 EST
One-line fix, but I'll let management decide whether to get this into
5.2 or 5.3.  For now I'll set the flags and assume 5.3 accordingly.

It's unknown how likely this will hit.  I tried a few things
this morning and didn't seem to hit it, so maybe it's unlikely.
If it does hit, it will likely cause a hang though.
Comment 3 Robert Peterson 2008-02-06 11:41:44 EST
Oops.  I just discovered I accidentally included this fix in the
253990 (performance) bugzilla that has gone into RHEL5.2.  
So this does not need fixing anymore.  Closing it out as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.