Bug 429569 - firstboot does not allow all modifications in non-graphical mode
firstboot does not allow all modifications in non-graphical mode
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-kdump (Show other bugs)
x86_64 All
low Severity medium
: rc
: ---
Assigned To: David Lehman
Linda Wang
Depends On:
  Show dependency treegraph
Reported: 2008-01-21 13:20 EST by IBM Bug Proxy
Modified: 2011-05-23 13:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-05-23 13:41:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 41405 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-01-21 13:20:21 EST
=Comment: #0=================================================
Michael Kravetz <mkravetz@us.ibm.com> - 2008-01-04 17:52 EDT
---Problem Description---
'firstboot' when run in non-graphical(text) mode does not allow for modification
of all settings.  Specificaly, it does not allow one to enable/configure kdump.
Contact Information = Mike Kravetz <kravetz@us.ibm.com>
---uname output---
Linux elm3b185.beaverton.ibm.com 2.6.18-53.el5 #1 SMP Wed Oct 10 16:34:19 EDT
2007 x86_64 x86_64 x86_64 GNU/Linux
Machine Type = LS21 Blade
A debugger is not configured
---Steps to Reproduce---
install RHEL5.1 in text mode and wait for firstboot to run after first boot
---Installation and Packaging Component Data--- 
Install disk info:
Install method: pxe boot, NFS install
Install ISO information: RHEL5.1

Userspace tool common name: firstboot

The userspace tool has the following bit modes: ?

Userspace rpm: firstboot-tui-
*Additional Instructions for Mike Kravetz <kravetz@us.ibm.com>: 
-Attach Anaconda install logs to the bug (/var/log/anaconda*).
-Attach ltrace and strace of userspace application.
=Comment: #1=================================================
Cijurajan Kollanoor <cijurajan@in.ibm.com> - 2008-01-07 08:18 EDT
The firstboot text mode does not allow to configure the kdump. 

I am pasting some lines of code from the file textWindow.py

32 class TextWindow:
33     def __call__(self, screen):
34         toolList = [(_("Authentication"), ("/usr/sbin/authconfig-tui"), ("")),
35                     (_("Firewall configuration"),
("/usr/bin/system-config-securitylevel-tui"), ("")),
36                     (_("Keyboard configuration"),
("/usr/bin/system-config-keyboard"), ("--text")),
37                     (_("Network configuration"),
("/usr/sbin/system-config-network-tui"), ("")),
38                     (_("Printer configuration"), ("/usr/sbin/printconf-tui"),
39                     (_("System services"), ("/usr/sbin/ntsysv"), ("")),
40                     (_("Timezone configuration"), ("/usr/sbin/timeconfig"),

So the user would not be able to see the option to configure kdump.

=Comment: #2=================================================
Cijurajan Kollanoor <cijurajan@in.ibm.com> - 2008-01-07 08:19 EDT
There are couple of options missing in the text based firstboot command,
compared to the GUI version.

Why are not all the config options supported in text mode?  Is text mode supported at all?  If text
mode is supported, where are the differences in capabilities between graphic and text mode
described/documented? Please could Redhat clarify the following issues for us.
Comment 1 Neil Horman 2008-01-21 14:11:37 EST
this needs to go do dave lehman.

Dave, I think what we need here is a tui variant in the s-c-kdump package, and
then to have that added to the tool list in firstboot.  Thanks!
Comment 2 David Lehman 2008-01-21 14:36:21 EST
I had an RFE to write a text interface for system-config-kdump and I rejected it
because the number of text mode users is too low to justify the additional
effort. For s-c-kdump there is no reason why one cannot run it via ssh or
similar, rendering a text user interface superfluous. 

I am planning to pull the kdump firsboot module into s-c-kdump, hopefully for
5.3, but I have no plans to write a text interface at this time. Generally, it
is expected that users who do not configure graphical startup are technically
adept enough to know if they want to set up kdump.
Comment 3 IBM Bug Proxy 2008-01-23 12:09:14 EST
------- Comment From mkravetz@us.ibm.com 2008-01-23 12:03 EDT-------
We can close.  I will suggest customers not use text mode install as there is an
undocumented lack of functionality.
Comment 4 IBM Bug Proxy 2008-01-23 12:24:57 EST
------- Comment From mkravetz@us.ibm.com 2008-01-23 12:18 EDT-------
i would say 'will not fix'.  but, you can make an argument for either.
Comment 5 IBM Bug Proxy 2008-01-23 13:34:34 EST
------- Comment From mkravetz@us.ibm.com 2008-01-23 13:17 EDT-------
yes, i will close it right now
Comment 6 IBM Bug Proxy 2008-01-23 18:48:28 EST
------- Comment From mranweil@us.ibm.com 2008-01-23 18:40 EDT-------
Red Hat: we closed this on our side as wontfix.

Note You need to log in before you can comment on or make changes to this bug.