Red Hat Bugzilla – Bug 429591
rawhide openldap does not "obsolete" compat-openldap from F8
Last modified: 2008-01-22 07:05:23 EST
Description of problem:
When trying to test if a yum upgrade would work I got a message
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1. Install compat-openldap in F8
2. Set repositories to include Rawhide as well as F8
3. yum upgrade
Error: Missing Dependency: openldap = 2.3.39-1.fc8 is needed by package
yum upgrade success
You can also just update openldap, but this will still force a lot of packages
Uninstalling compat-openldap before the upgrade works around the problem.
Strange, openldap-2.4.7.rpm has "Obsoletes: compat-openldap <=2.3". It seems
that "Obsoletes" doesn't works as I expect. I'll look at it.
Please fix this _with_ a version, not with an unversioned
Obsoletes, in order to not block the entire compat-openldap
> Obsoletes: compat-openldap <=2.3
In F8 Updates it is compat-openldap-2.3.39_2.2.29-1.fc8.i386.rpm
which is _higher than_ "2.3".
You could use Obsoletes: compat-openldap < 2.4
or even Obsoletes: compat-openldap <= 2.3.39_2.2.29
Fixed in openldap-2.4.7-2