This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 429591 - rawhide openldap does not "obsolete" compat-openldap from F8
rawhide openldap does not "obsolete" compat-openldap from F8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 15:47 EST by Bruno Wolff III
Modified: 2008-01-22 07:05 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 07:05:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2008-01-21 15:47:56 EST
Description of problem:
When trying to test if a yum upgrade would work I got a message

Version-Release number of selected component (if applicable):
2.4.7-1.fc9

How reproducible:
100%

Steps to Reproduce:
1. Install compat-openldap in F8
2. Set repositories to include Rawhide as well as F8
3. yum upgrade
  
Actual results:
Error: Missing Dependency: openldap = 2.3.39-1.fc8 is needed by package
compat-openldap

Expected results:
yum upgrade success

Additional info:
You can also just update openldap, but this will still force a lot of packages
to upgrade.
Uninstalling compat-openldap before the upgrade works around the problem.
Comment 1 Jan Safranek 2008-01-22 04:49:53 EST
Strange, openldap-2.4.7.rpm has "Obsoletes: compat-openldap <=2.3". It seems
that "Obsoletes" doesn't works as I expect. I'll look at it.
Comment 2 Michael Schwendt 2008-01-22 06:50:27 EST
Please fix this _with_ a version, not with an unversioned
Obsoletes, in order to not block the entire compat-openldap
namespace.

> Obsoletes: compat-openldap <=2.3

In F8 Updates it is compat-openldap-2.3.39_2.2.29-1.fc8.i386.rpm 
which is _higher than_ "2.3".

You could use   Obsoletes: compat-openldap < 2.4
or even  Obsoletes: compat-openldap <= 2.3.39_2.2.29
Comment 3 Jan Safranek 2008-01-22 07:05:23 EST
Fixed in openldap-2.4.7-2

Note You need to log in before you can comment on or make changes to this bug.