Bug 429591 - rawhide openldap does not "obsolete" compat-openldap from F8
Summary: rawhide openldap does not "obsolete" compat-openldap from F8
Alias: None
Product: Fedora
Classification: Fedora
Component: openldap   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Jan Safranek
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2008-01-21 20:47 UTC by Bruno Wolff III
Modified: 2008-01-22 12:05 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-22 12:05:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Bruno Wolff III 2008-01-21 20:47:56 UTC
Description of problem:
When trying to test if a yum upgrade would work I got a message

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install compat-openldap in F8
2. Set repositories to include Rawhide as well as F8
3. yum upgrade
Actual results:
Error: Missing Dependency: openldap = 2.3.39-1.fc8 is needed by package

Expected results:
yum upgrade success

Additional info:
You can also just update openldap, but this will still force a lot of packages
to upgrade.
Uninstalling compat-openldap before the upgrade works around the problem.

Comment 1 Jan Safranek 2008-01-22 09:49:53 UTC
Strange, openldap-2.4.7.rpm has "Obsoletes: compat-openldap <=2.3". It seems
that "Obsoletes" doesn't works as I expect. I'll look at it.

Comment 2 Michael Schwendt 2008-01-22 11:50:27 UTC
Please fix this _with_ a version, not with an unversioned
Obsoletes, in order to not block the entire compat-openldap

> Obsoletes: compat-openldap <=2.3

In F8 Updates it is compat-openldap-2.3.39_2.2.29-1.fc8.i386.rpm 
which is _higher than_ "2.3".

You could use   Obsoletes: compat-openldap < 2.4
or even  Obsoletes: compat-openldap <= 2.3.39_2.2.29

Comment 3 Jan Safranek 2008-01-22 12:05:23 UTC
Fixed in openldap-2.4.7-2

Note You need to log in before you can comment on or make changes to this bug.