Bug 429595 - [PATCH] Compile the python bindings into a subpackage
[PATCH] Compile the python bindings into a subpackage
Status: CLOSED DUPLICATE of bug 273821
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 16:11 EST by John (J5) Palmieri
Modified: 2013-03-13 00:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 01:58:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patches the spec file to create the python subpackage (2.57 KB, patch)
2008-01-21 16:11 EST, John (J5) Palmieri
no flags Details | Diff
Patch which is used by the spec file to point the python build scripts to the correct directory to find libmagic (546 bytes, patch)
2008-01-21 16:12 EST, John (J5) Palmieri
no flags Details | Diff

  None (edit)
Description John (J5) Palmieri 2008-01-21 16:11:00 EST
Description of problem:

file (or libmagic as the library is called) contains useful python bindings that
we do not build.

Attached is a patch to the spec file to build a python sub package (which also
provides python-magic as it is known on other distributions).  There is also a
patch that the spec file applies to the setup.py builder so that the bindings
will look in ../src/.libs/ for the recently built libmagic.
Comment 1 John (J5) Palmieri 2008-01-21 16:11:00 EST
Created attachment 292413 [details]
Patches the spec file to create the python subpackage
Comment 2 John (J5) Palmieri 2008-01-21 16:12:28 EST
Created attachment 292414 [details]
Patch which is used by the spec file to point the python build scripts to the correct directory to find libmagic
Comment 3 John (J5) Palmieri 2008-01-21 16:13:19 EST
BTW I need this for F-8 but can also be pushed to devel
Comment 4 Tomas Smetana 2008-01-22 01:58:28 EST
I have already been working on that.  I only didn't have much time for this
recently.  There remains to solve the problem with the License tag and I hope I
can push the update.

*** This bug has been marked as a duplicate of 273821 ***

Note You need to log in before you can comment on or make changes to this bug.