Bug 429620 - Selinux AVC in Open Office Writer when attempting to use frame macros (dlopened libjvm.so)
Selinux AVC in Open Office Writer when attempting to use frame macros (dlopen...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 17:50 EST by James Wilkinson
Modified: 2008-01-30 07:13 EST (History)
1 user (show)

See Also:
Fixed In Version: selinux-policy-3.0.8-81.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 07:13:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Wilkinson 2008-01-21 17:50:55 EST
Description of problem:
Selinux AVC in Open Office Writer when attempting to use frame macros

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.3.0-6.7.fc8.x86_64
selinux-policy-targeted-3.0.8-74.fc8.noarch

Steps to Reproduce:
1. Open OpenOffice Writer
2. Insert menu -> Frame
3. Click on Macro tab
  
Actual results:
SELinux AVC denial, click icon to view

In setroubleshoot browser
SELinux is preventing /usr/lib64/openoffice.org/program/swriter.bin from making
the program stack executable.

Additional info:
SELinux is enabled in enforcing mode.

chcon -t unconfined_execmem_exec_t /usr/lib64/openoffice.org/program/swriter.bin
works around this issue, but this should not be necessary.

OpenOffice does not respond well to these denials -- it racks up hundreds of AVC
denials in seconds.
Comment 1 Caolan McNamara 2008-01-22 02:40:42 EST
Which java is being executed here, i.e. what's selected in 
tools->options->openoffice.org->java
Comment 2 Daniel Walsh 2008-01-22 09:28:33 EST
This is a labeling problem
 matchpathcon /usr/lib64/openoffice.org/program/swriter.bin
/usr/lib64/openoffice.org/program/swriter.bin	system_u:object_r:lib_t:s0
 matchpathcon /usr/lib/openoffice.org/program/swriter.bin
/usr/lib/openoffice.org/program/swriter.bin
system_u:object_r:unconfined_execmem_exec_t:s0

Fixed in selinux-policy-3.0.8-81.fc8
Comment 3 James Wilkinson 2008-01-30 07:13:33 EST
Thanks a lot, after updating this works for me.

Note You need to log in before you can comment on or make changes to this bug.