Bug 429628 - wxGTK version conflicts w wxGTK from dag repo
wxGTK version conflicts w wxGTK from dag repo
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: wxGTK (Show other bugs)
el4
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 19:25 EST by Dave Botsch
Modified: 2008-01-22 01:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 01:24:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Botsch 2008-01-21 19:25:08 EST
Description of problem:
Dag's EL4 repo has at least one package (vlc) built against wxGTK2.6 -- epel's
repo has a newer wxGTK - 2.8 - presumably required by packages in epel. Clearly,
this causes issues.


Version-Release number of selected component (if applicable):
2.8.4-4.el4.1


How reproducible:
100%


Steps to Reproduce:
1.install wxGTK from epel (or set up both the epel and dag repos in yum)
2.try doing a 'yum install vlc'
3.failure
  
Actual results:
cannot install vlc due to epel's wxGTK being selected over the dag one

Expected results:
vlc installs

Additional info:
It would be great if you guys could coordinate w. dag (and the other repos out
there) to help avoid issues like this. While I am aware of yum plugins that
allow one to specify repo priorities (in my case, epel is a higher prioritiy
than dag due to my needing the lower versioned epel wine over the higher
versioned dag wine), clearly now I need the lower versioned dag wxGTK over the
higher versioned epel wxGTK - so, I need the priorities in both directions *sigh*
Comment 1 Dan Horák 2008-01-22 01:24:49 EST
Sorry, but when mixing repos, you must solve the conflicts yourself. Probably an
exclude list containing wxGTK in the EPEL repo definition will workaround this
conflict.

Note You need to log in before you can comment on or make changes to this bug.