Bug 429632 - [fluxbox] openoffice dropdown menus positioned outside of window
[fluxbox] openoffice dropdown menus positioned outside of window
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 20:21 EST by Michael Ploujnikov
Modified: 2008-07-02 00:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.3.0-6.14.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:41:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
visual display of the bug (153.75 KB, image/png)
2008-01-21 20:21 EST, Michael Ploujnikov
no flags Details
differences in the xorg.conf on test machines (1.02 KB, text/plain)
2008-01-21 20:23 EST, Michael Ploujnikov
no flags Details
bug as seen in single-display mode (84.95 KB, image/png)
2008-01-24 15:21 EST, Michael Ploujnikov
no flags Details
xorg.conf under which the bug is reproducible for me (1.63 KB, text/plain)
2008-01-24 15:23 EST, Michael Ploujnikov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 86882 None None None Never

  None (edit)
Description Michael Ploujnikov 2008-01-21 20:21:22 EST
Description of problem:
OpenOffice.org dropdown menus appear positioned outside of the applications
window and having the right side aligned with the right-most edge of the current
desktop/workspace when using Fluxbox as the window manager.

Version-Release number of selected component (if applicable):
openoffice.org-writer x86_64 2.3.0 6.7.fc8
fluxbox x86_64 1.0.0 2.fc8
xorg-x11-server-Xorg x86_64 1.3.0.0 37.fc8

How reproducible:
can always reproduce it on my own desktop machine under my user account and
under a newly created test account when using Fluxbox
can reproduce on my desktop machine with official nvidia drivers as well as the
livna ones
cannot reproduce on another F8 i686 athlon machine that uses the same version of
livna's nVidia drivers, fluxbox and openoffice.org-writer
can still reproduce on my machine with twinview disabled (and using a xorg.conf
as much similar to the other box's as possible - see the attached xorg.conf diff)
cannot reproduce this in Gnome on any machines.

Steps to Reproduce:
1. $ oowriter
2. left click the mouse on any of the following menus: File, Edit, View, Insert,
Format, Table, Tools, Window, Help
3. note the dropdown menu location

Actual results:
the dropdown menu appears to have the right side aligned against the right-most
edge of the desktop
see the attached .PNG

Expected results:
the dropdown menu appears vertically aligned with the left edge of text which
was clicked on to trigger this dropdown

Additional info:
dropdowns always appear at the expected height
dropdowns that appear when right-clicking on the document also exhibit this bug
Comment 1 Michael Ploujnikov 2008-01-21 20:21:22 EST
Created attachment 292430 [details]
visual display of the bug
Comment 2 Michael Ploujnikov 2008-01-21 20:23:25 EST
Created attachment 292431 [details]
differences in the xorg.conf on test machines

the /etc/X11/xorg.conf is from my main desktop machine and the /tmp/xorg.conf
is from the secondary test machine that does not exhibit this bug
Comment 3 Caolan McNamara 2008-01-22 02:43:08 EST
Can you reproduce this on any box that is not using binary drivers ?
Comment 4 Michael Ploujnikov 2008-01-22 09:13:16 EST
I was able to reproduce this on my main desktop by setting

Driver      "nv"

in xorg.conf.
Comment 5 Caolan McNamara 2008-01-24 11:22:08 EST
caolanm->jnavrati: Can you see if you can reproduce this on a dual-head setup ?
Comment 6 Michael Ploujnikov 2008-01-24 15:21:37 EST
Created attachment 292851 [details]
bug as seen in single-display mode

using the "nv" driver
Comment 7 Michael Ploujnikov 2008-01-24 15:23:40 EST
Created attachment 292852 [details]
xorg.conf under which the bug is reproducible for me

Some sections are commented out for testing purposes but the bug happens with
those sections not commented out as well.
Comment 8 Caolan McNamara 2008-03-10 10:06:10 EDT
I can reproduce this now, needs to be fluxbox to see this
Comment 9 Michael Ploujnikov 2008-03-10 10:27:50 EDT
As the original reporter I shall mention that I can still reproduce this even
after switching from Fluxbox to xmonad.
Comment 10 Caolan McNamara 2008-03-10 10:34:34 EDT
you may find that explictly disabling the gtk plugin with e.g. 

export SAL_USE_VCLPLUGIN=gen

will give a variant where the menus are in the right place, with the drawback of
looking like a throwback to 1980
Comment 11 Caolan McNamara 2008-03-10 11:12:51 EDT
bah, negative -1 widths for decorations on windows, which falls into a comedy of
casting errors that makes them from unsigned ints into longs and so end up as
huge positive numbers not -1 and they get clipped to the edge of the screen.

Got the menus fixed, just need to track down some other ones wrt some dialogs.
Comment 12 Caolan McNamara 2008-03-10 11:48:55 EDT
fix checked in, will be in >= 
openoffice_org-2.3.0-6.12.fc8 / openoffice_org-2.4.0-10.2.fc9
Comment 13 Michael Ploujnikov 2008-03-10 18:04:10 EDT
(In reply to comment #10)
> you may find that explictly disabling the gtk plugin with e.g. 
> 
> export SAL_USE_VCLPLUGIN=gen

That fixes the problem.

> will give a variant where the menus are in the right place, with the drawback of
> looking like a throwback to 1980

I don't care :)
Comment 14 Fedora Update System 2008-03-20 04:07:33 EDT
openoffice.org-2.3.0-6.12.fc8 has been submitted as an update for Fedora 8
Comment 15 Fedora Update System 2008-03-21 18:01:59 EDT
openoffice.org-2.3.0-6.12.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2552
Comment 16 Fedora Update System 2008-04-08 14:41:01 EDT
openoffice.org-2.3.0-6.13.fc8 has been submitted as an update for Fedora 8
Comment 17 Fedora Update System 2008-04-17 14:38:40 EDT
openoffice.org-2.3.0-6.14.fc8 has been submitted as an update for Fedora 8
Comment 18 Fedora Update System 2008-04-22 18:41:02 EDT
openoffice.org-2.3.0-6.14.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Yolkfull Chow 2008-07-02 00:32:16 EDT
Verified this bug and problem disappeared.

fluxbox-1.0.0-5.fc9.i386
openoffice.org-writer-2.4.1-17.4.fc9.i386
xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.i386

Note You need to log in before you can comment on or make changes to this bug.