Bug 429633 - gfs_tool doesn't recognize GFS file sytem
gfs_tool doesn't recognize GFS file sytem
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-utils (Show other bugs)
5.1
ppc64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Robert Peterson
GFS Bugs
:
Depends On:
Blocks: Cluster5-ppc 430154
  Show dependency treegraph
 
Reported: 2008-01-21 20:24 EST by Nate Straz
Modified: 2010-01-11 22:33 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0347
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:58:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (16.01 KB, patch)
2008-01-23 12:34 EST, Robert Peterson
no flags Details | Diff
Revised patch (16.14 KB, patch)
2008-01-24 15:45 EST, Robert Peterson
no flags Details | Diff

  None (edit)
Description Nate Straz 2008-01-21 20:24:43 EST
Description of problem:

When I tried to turn on jdata with gfs_tool on a ppc cluster I got the following
error:

gfs_tool: /mnt/gfs_vs0 is not a GFS file/filesystem

and the following message on the console:

ioctl32(gfs_tool:6952): Unknown cmd fd(3) cmd(00004723){00} arg(ff98f8bc) on
/mnt/gfs_vs0

Version-Release number of selected component (if applicable):
gfs-utils-0.1.12-1.el5
kmod-gfs-0.1.19-7.el5_1.1
kernel-2.6.18-53.1.6.el5


How reproducible:
Every time

Steps to Reproduce:
1. mount GFS file system on a ppc system
2. gfs_tool getsb /mnt/gfs
  
Actual results:

Every command I've tried (getsb, stat, and inherit_jdata) doesn't recognize the
file system as GFS.
Expected results:


Additional info:
Comment 1 Robert Peterson 2008-01-23 12:34:57 EST
Created attachment 292677 [details]
Proposed patch

This patch seems to work on both ppc and x86_64 architecture.
It's a bit big and a bit of a kludge.  However, hopefully it will only
affect systems that need compatibility ioctls, such as the failing case.
Also, it doesn't affect userland.
Comment 2 Rob Kenna 2008-01-23 16:13:25 EST
So this looks to be needed for 5.1z too.
Comment 3 Robert Peterson 2008-01-24 15:45:43 EST
Created attachment 292853 [details]
Revised patch

This version has some small cleanups.  For one thing, it only
allocates as much memory as required rather than NAME_MAX for
the copies parameters.	Also, it fixes some formatting mistakes.
Comment 5 Robert Peterson 2008-01-24 16:30:32 EST
Fix was committed to the HEAD and RHEL5 branches of CVS (plus a
crosswrite to the RHEL51 branch for bug #430154).  Changing status
to Modified.

The predecessor patch was tested on the failing ppc/ppc64 system
"basic" and on x86_64 system "roth-01".  This patch was tested on
roth-01, but "basic" was reassigned to another purpose, so I don't
currently have a ppc system to test it on.
Comment 8 errata-xmlrpc 2008-05-21 11:58:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0347.html

Note You need to log in before you can comment on or make changes to this bug.