This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 429655 - openais build error on ia64: open with O_CREAT needs 3 arguments
openais build error on ia64: open with O_CREAT needs 3 arguments
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openais (Show other bugs)
rawhide
ia64 Linux
low Severity low
: ---
: ---
Assigned To: Steven Dake
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-01-22 02:09 EST by Zhan, Yi
Modified: 2016-04-26 09:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 17:54:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhan, Yi 2008-01-22 02:09:17 EST
Description of problem:

I encountered the build error when try to build openais on IA64. The error is
caused by exec/keygen.c, line 75:

    authkey_fd = open ("/etc/ais/authkey", O_CREAT|O_WRONLY);

Adding the third argument could fix it.

    authkey_fd = open ("/etc/ais/authkey", O_CREAT|O_WRONLY,
S_IRUSR|S_IWUSR|S_IRGRP);

Version-Release number of selected component (if applicable):
openais-0.80.1-6.src.rpm

How reproducible:
always

Steps to Reproduce:
1. rpmbuild --rebuild openais-0.80.1-6.src.rpm
2.
3.
  
Actual results:

/usr/include/bits/fcntl2.h:51: error: call to '__open_missing_mode' declared
with attribute error: open with O_CREAT in second argument
needs 3 arguments                                                              
                                                         
make[1]: *** [keygen.o] Error 1

Expected results:

Build cleanly

Additional info:
Comment 1 Doug Chapman 2008-03-05 17:54:44 EST
This is now building cleanly in rawhide.

Note You need to log in before you can comment on or make changes to this bug.