Bug 429674 - unzip regression
unzip regression
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: unzip (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 07:23 EST by Luciano Rocha
Modified: 2010-02-16 17:16 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.52-6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 566273 (view as bug list)
Environment:
Last Closed: 2008-02-07 15:55:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Luciano Rocha 2008-01-22 07:23:42 EST
Description of problem:

Current F8 and rawhide unzip fails to uncompress/test/list a valid zip file. The
version in CentOS 4.6 works correctly.

unzip -l ....zip

$ unzip -l ....zip
Archive:  .....zip
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of K....zip or
        ....zip.zip, and cannot find ....zip.ZIP, period.

$ ./unzip.c4.6 -l ....zip
Archive:  ....zip
  Length     Date   Time    Name
 --------    ----   ----    ----
....
 --------                   -------
405190016                   14 files

The file is larger than 2GB:
$ ls -l ....zip
-rw-rw-r-- 1 luciano luciano 3769323791 2008-01-21 06:06 ....zip

Version-Release number of selected component (if applicable):
$ rpm -q unzip
unzip-5.52-5.fc8
 $ unzip -v
UnZip 5.52 of 28 February 2005, by Info-ZIP.  Maintained by C. Spieler.  Send
bug reports using http://www.info-zip.org/zip-bug.html; see README for details.

Latest sources and executables are at ftp://ftp.info-zip.org/pub/infozip/ ;
see ftp://ftp.info-zip.org/pub/infozip/UnZip.html for other sites.

Compiled with gcc 4.1.2 20070925 (Red Hat 4.1.2-33) for Unix (Linux ELF) on Jan
22 2008.

UnZip special compilation options:
        COPYRIGHT_CLEAN (PKZIP 0.9x unreducing method not supported)
        SET_DIR_ATTRIB
        TIMESTAMP
        USE_EF_UT_TIME
        USE_UNSHRINK (PKZIP/Zip 1.x unshrinking method supported)
        USE_DEFLATE64 (PKZIP 4.x Deflate64(tm) supported)
        VMS_TEXT_CONV
        [decryption, version 2.9 of 05 May 2000]

UnZip and ZipInfo environment options:
           UNZIP:  [none]
        UNZIPOPT:  [none]
         ZIPINFO:  [none]
      ZIPINFOOPT:  [none]

Version that works:
$ ./unzip.c4.6 -v
UnZip 5.51 of 22 May 2004, by Info-ZIP.  Maintained by C. Spieler.  Send
bug reports using http://www.info-zip.org/zip-bug.html; see README for details.

Latest sources and executables are at ftp://ftp.info-zip.org/pub/infozip/ ;
see ftp://ftp.info-zip.org/pub/infozip/UnZip.html for other sites.

Compiled with gcc 3.4.6 20060404 (Red Hat 3.4.6-8) for Unix (Linux ELF) on May 
3 2007.

UnZip special compilation options:
        COPYRIGHT_CLEAN (PKZIP 0.9x unreducing method not supported)
        LZW_CLEAN (PKZIP/Zip 1.x unshrinking method not supported)
        SET_DIR_ATTRIB
        TIMESTAMP
        USE_EF_UT_TIME
        USE_DEFLATE64 (PKZIP 4.x Deflate64(tm) supported)
        VMS_TEXT_CONV
        [decryption, version 2.9 of 05 May 2000]

UnZip and ZipInfo environment options:
           UNZIP:  [none]
        UNZIPOPT:  [none]
         ZIPINFO:  [none]
      ZIPINFOOPT:  [none]


How reproducible:

Always, with that specific file. I don't have other .zip files larger than 2GB.

Additional info:

Due to copyrights, I can't give more information about the zip file, but I'll do
more tests that you require.
Comment 1 Ivana Varekova 2008-01-22 09:36:06 EST
Please could you try to reproduce your problem with the last devel version -
unzip-5.52-6.fc9 - it contains patch which could fix it (version
unzip-5.52-5.fc9 should be affected by this bug too - but it would be great if
you could test this too). I will add the same patch to fc8 when I will be sure
it fixes the problem.
Thanks.
Comment 2 Luciano Rocha 2008-01-22 10:33:42 EST
I can't find it. I can only find unzip-5.52-5.fc8 in rawhide, that I already
tested (and it didn't work).

I've just checked
ftp://download.fedora.redhat.com/pub/fedora/linux/development/, and I still see
only 5.52-5.fc8.

Could you provide me a link? Or create an attachment with it?
Comment 3 Ivana Varekova 2008-01-22 10:40:43 EST
It is on http://koji.fedoraproject.org/koji/buildinfo?buildID=32485.
Thanks
Comment 4 Luciano Rocha 2008-01-22 11:27:53 EST
(In reply to comment #3)
> It is on http://koji.fedoraproject.org/koji/buildinfo?buildID=32485.
> Thanks

No luck, still same error.

$ unzip -v
UnZip 5.52 of 28 February 2005, by Info-ZIP.  Maintained by C. Spieler.  Send
bug reports using http://www.info-zip.org/zip-bug.html; see README for details.

Latest sources and executables are at ftp://ftp.info-zip.org/pub/infozip/ ;
see ftp://ftp.info-zip.org/pub/infozip/UnZip.html for other sites.

Compiled with gcc 4.1.2 20071124 (Red Hat 4.1.2-36) for Unix (Linux ELF) on Jan
22 2008.

UnZip special compilation options:
        COPYRIGHT_CLEAN (PKZIP 0.9x unreducing method not supported)
        SET_DIR_ATTRIB
        TIMESTAMP
        USE_EF_UT_TIME
        USE_UNSHRINK (PKZIP/Zip 1.x unshrinking method supported)
        USE_DEFLATE64 (PKZIP 4.x Deflate64(tm) supported)
        VMS_TEXT_CONV
        [decryption, version 2.9 of 05 May 2000]

UnZip and ZipInfo environment options:
           UNZIP:  [none]
        UNZIPOPT:  [none]
         ZIPINFO:  [none]
      ZIPINFOOPT:  [none]
Comment 5 Ivana Varekova 2008-01-23 08:39:47 EST
Thanks for your help. 
I just look at this problem and find another bug - I hope there is fixed all LFS
stuff. So could you please test  unzip-5.52-7.fc9 - it is on 
http://koji.fedoraproject.org/koji/taskinfo?taskID=367683.
Comment 6 Luciano Rocha 2008-01-23 12:44:32 EST
It works now, thanks. Tested unzip -l, -t and normal extraction (includes a
4700000000 file).
Comment 7 Ivana Varekova 2008-01-24 03:22:25 EST
There is just added fixed version for fc8 (unzip-5.52-6.fc8) branch to testing
repository - it will be in stable soon.
Thanks for your excelent help with investigating this problem :).

Comment 8 Luciano Rocha 2008-01-25 07:07:36 EST
Not at all, and thank you for the quick resolution.
Comment 9 Fedora Update System 2008-01-27 02:19:30 EST
unzip-5.52-6.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update unzip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/F8/FEDORA-2008-1061
Comment 10 Luciano Rocha 2008-01-28 04:45:35 EST
That link returns a "File Not Found" error.
Comment 11 Ivana Varekova 2008-01-28 05:38:33 EST
Thanks. The right link is:
https://admin.fedoraproject.org/updates/F8/FEDORA-2008-1061
I'm just investigating what causes the previous bogus link.
Comment 12 Fedora Update System 2008-02-07 15:55:35 EST
unzip-5.52-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Dax Kelson 2010-02-16 17:16:34 EST
RHEL5 needs this 4GB patch for unzip. Can this bug be cloned over for RHEL5?

Note You need to log in before you can comment on or make changes to this bug.