Bug 429677 - SELinux is preventing semanage (semanage_t) "write" to /dev/null (device_t).
SELinux is preventing semanage (semanage_t) "write" to /dev/null (device_t).
Status: CLOSED DUPLICATE of bug 429678
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-01-22 07:43 EST by Valent Turkovic
Modified: 2008-02-19 08:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-19 08:48:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Valent Turkovic 2008-01-22 07:43:34 EST
Description of problem:
    SELinux is preventing semanage (semanage_t) "write" to /dev/null (device_t).

Detailed Description
    SELinux denied access requested by semanage. It is not expected that this
    access is required by semanage and this access may signal an intrusion
    attempt. It is also possible that the specific version or configuration of
    the application is causing it to require additional access.

Allowing Access
    Sometimes labeling problems can cause SELinux denials.  You could try to
    restore the default system file context for /dev/null, restorecon -v
    /dev/null If this does not work, there is currently no automatic way to
    allow this access. Instead,  you can generate a local policy module to allow
    this access - see http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385
    Or you can disable SELinux protection altogether. Disabling SELinux
    protection is not recommended. Please file a
    http://bugzilla.redhat.com/bugzilla/enter_bug.cgi against this package.

Additional Information        

Source Context                system_u:system_r:semanage_t:s0
Target Context                system_u:object_r:device_t:s0
Target Objects                /dev/null [ file ]
Affected RPM Packages         
Policy RPM                    selinux-policy-3.0.8-74.fc8
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   plugins.catchall_file
Host Name                     valent.oswireless
Platform                      Linux valent.oswireless #1 SMP Fri
                              Dec 7 15:49:59 EST 2007 i686 i686
Alert Count                   9
First Seen                    Mon 21 Jan 2008 10:23:16 PM CET
Last Seen                     Tue 22 Jan 2008 01:17:55 PM CET
Local ID                      533ba70e-3897-4a74-a6b0-d9b32081a4ed
Line Numbers                  

Raw Audit Messages            

avc: denied { write } for comm=semanage dev=sda6 path=/dev/null pid=11435
scontext=system_u:system_r:semanage_t:s0 tclass=file

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. start fedora revisor and try to make live cd fased on F8 live cd
Actual results:

Expected results:

Additional info:
Comment 1 Josef Kubin 2008-02-19 08:48:40 EST

*** This bug has been marked as a duplicate of 429678 ***

Note You need to log in before you can comment on or make changes to this bug.