Bug 429686 - SELinux is preventing the /sbin/setfiles from using potentially mislabeled files (/var/tmp/revisorrevisor-yum.log).
SELinux is preventing the /sbin/setfiles from using potentially mislabeled fi...
Status: CLOSED DUPLICATE of bug 429678
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 08:22 EST by Valent Turkovic
Modified: 2008-01-23 16:30 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 16:30:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valent Turkovic 2008-01-22 08:22:37 EST
Description of problem:
Summary
    SELinux is preventing the /sbin/setfiles from using potentially mislabeled
    files (/var/tmp/revisorrevisor-yum.log).

Detailed Description
    SELinux has denied /sbin/setfiles access to potentially mislabeled file(s)
    (/var/tmp/revisorrevisor-yum.log).  This means that SELinux will not allow
    /sbin/setfiles to use these files.  It is common for users to edit files in
    their home directory or tmp directories and then move (mv) them to system
    directories.  The problem is that the files end up with the wrong file
    context which confined applications are not allowed to access.

Allowing Access
    If you want /sbin/setfiles to access this files, you need to relabel them
    using restorecon -v /var/tmp/revisorrevisor-yum.log.  You might want to
    relabel the entire directory using restorecon -R -v /var/tmp.

Additional Information        

Source Context                system_u:system_r:setfiles_t:s0
Target Context                system_u:object_r:unconfined_tmp_t:s0
Target Objects                /var/tmp/revisorrevisor-yum.log [ file ]
Affected RPM Packages         policycoreutils-2.0.33-3.fc8 [application]
Policy RPM                    selinux-policy-3.0.8-74.fc8
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   plugins.home_tmp_bad_labels
Host Name                     valent.oswireless
Platform                      Linux valent.oswireless 2.6.23.9-85.fc8 #1 SMP Fri
                              Dec 7 15:49:59 EST 2007 i686 i686
Alert Count                   1
First Seen                    Tue 22 Jan 2008 01:52:36 PM CET
Last Seen                     Tue 22 Jan 2008 01:52:36 PM CET
Local ID                      5ccce197-dbc7-4a45-83c6-9d43a1dcc37c
Line Numbers                  

Raw Audit Messages            

avc: denied { append } for comm=setfiles dev=sda6 egid=0 euid=0
exe=/sbin/setfiles exit=0 fsgid=0 fsuid=0 gid=0 items=0 path=/var/tmp
/revisorrevisor-yum.log pid=30307 scontext=system_u:system_r:setfiles_t:s0
sgid=0 subj=system_u:system_r:setfiles_t:s0 suid=0 tclass=file
tcontext=system_u:object_r:unconfined_tmp_t:s0 tty=(none) uid=0



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. revisor issue
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Walsh 2008-01-23 16:30:25 EST

*** This bug has been marked as a duplicate of 429678 ***

Note You need to log in before you can comment on or make changes to this bug.