Bug 42970 - wu-ftpd has long delay while connecting
wu-ftpd has long delay while connecting
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-30 22:33 EDT by Tom Wood
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-30 22:33:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Wood 2001-05-30 22:33:05 EDT
Description of Problem: wu-ftpd performs a reverse DNS lookup for incoming connections and this option can't be defeated


How Reproducible: Every time.


Steps to Reproduce:
1. install wu-ftpd 2.6-1-16 from RPM on RH71 CD1.
2. connect to the wu-ftpd server from a machine that's not resolvable in the reverse DNS.
3.  experience delay of 30 seconds between client connecting to wu-ftpd server and username prompt.

Actual Results: 30 second delay before allowed to enter username.


Expected Results: Near instantaneous response with username prompt.


Additional Information: wu-ftpd can't be told to not perform a reverse DNS lookup.  The "-I" option doesn't help (switching off ident).  The version in this RPM seems to have been compiled with a switch requiring reverse DNS.  Having the connecting host in the /etc/hosts file doesn't help.  Disabling DNS for the server running wu-ftpd by renaming/removing the /etc/resolv.conf file is the only workaround I've found, but this totally disables DNS lookups for the server.
Comment 1 Bernhard Rosenkraenzer 2001-05-31 03:26:56 EDT
This behavior is intentional - most people want to log hostnames rather 
than/in addition to IP addresses.
The right fix is to fix up the DNS responsible for the client's IP.

If you need to work around buggy DNS servers, you have to recompile with 
--disable-dns.

Comment 2 Tom Wood 2001-05-31 23:14:12 EDT
The right fix for this is to have a option to turn it off, rather than to assume that everyone using it has access to the DNS server from which the connections will be made.  Yeah, I could fix the world's DNS problems, but my schedule is already pretty packed.  Way too many times the reverse DNS entries are poorly maintained, often missing, especially by those administering Windoze boxes.

Oddly enough, this seems to be the only entry about this in bugzilla.  There are dozens of Internet references and deja entries with others upset about this.

Another troubling aspect of wu-ftpd is the wide variances from one revision to the next of /etc/ftp* entries, command line switches under which the package is compiled, etc.  We need some stability here.
Comment 3 Morco 2004-10-18 06:56:58 EDT
I have the same issue, but the delay is more than 30s ( around
2min).Our server is behind a firewall that drop connection after sync
timeout. Is it possible to turn off the reverse lookup option without
rebuild ?
Will be any release that implement this change.
PS: I have the same issue with telnet. 

Note You need to log in before you can comment on or make changes to this bug.