Bug 429753 - kpathsea is pulling in all of texlive
kpathsea is pulling in all of texlive
Status: CLOSED DUPLICATE of bug 428489
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 16:24 EST by Zack Cerza
Modified: 2013-07-02 19:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 00:30:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2008-01-22 16:24:08 EST
Description of problem:
kpathsea is pulling in all of texlive, which could be a problem for the livecd,
since evince requires kpathsea. That adds roughly 100MB in rpms.

Version-Release number of selected component (if applicable):
2007-13.fc9
Comment 1 Patrice Dumas 2008-01-22 16:49:35 EST
This is the duplicate of another bug, but I cannot find
it offhand. Anyway kpathsea calls programs from texlive
and evince needs fonts from texlive and the texlive machinery
to render dvi.
Comment 2 Jindrich Novy 2008-01-23 00:30:08 EST
The packaging modification of the baseline texlive package is in progress
already. The main ideas are to package xetex in texlive-xetex (removed
dependency on teckit-devel, dvipdfmx), packaging stuff using ghostscript and
metafont with X support in texlive-utils (removing dependendencies on X, Perl),
also we should consider Requires: mendex as it's not needed by anything in
texlive and is kept for a sole purpose of tetex compatibility. These changes
should be ready for commit during today.

*** This bug has been marked as a duplicate of 428489 ***

Note You need to log in before you can comment on or make changes to this bug.