Bug 429757 - Documentation for client API needs updated
Documentation for client API needs updated
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
urgent Severity low
: ---
: ---
Assigned To: Gordon Sim
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 16:37 EST by Alan Conway
Modified: 2011-08-12 12:22 EDT (History)
0 users

See Also:
Fixed In Version: rhm-docs-0.2-16.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-20 11:17:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2008-01-22 16:37:17 EST
Description of problem:

> 4. The top level C++ "API for an AMPQ client" doesn't have a link for Session
which is referenced in the code.

Additional info:

The Session type should be included in the client API list for doxygen 
generated docs. 

Session is actually a typedef for Session_0_10, which does not have 
very leglible API doc because of the boost macros used to create 
keyword arguments. no_keywords::Session_0_10 provides a non-keyword 
version of the API that is much easier to read.

Somehow this all needs to be tied together so the user can simply click
to Session and look up the parameters available.
Comment 1 Gordon Sim 2008-01-23 06:25:20 EST
As above, the Session is not included in the client api list, but neither are
most of the 'new' classes (SubscriptionManager etc). In addition some old
classes remain and must be marked as deprecated or removed entirely (preferable).

Consequently I renamed this bug to cover the wider scope.
Comment 2 Gordon Sim 2008-01-24 10:55:26 EST
Fixed in r614551
Comment 3 Mike Bonnet 2008-02-20 11:17:07 EST
Fixed in rhm-docs-0.2-16.el5

Note You need to log in before you can comment on or make changes to this bug.