Bug 429763 - Can't NFS install with kickstart via network
Can't NFS install with kickstart via network
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libdhcp (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 16:57 EST by Gary Thomas
Modified: 2008-01-24 16:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 20:47:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart image (1012 bytes, text/plain)
2008-01-22 16:57 EST, Gary Thomas
no flags Details
Handle re-add of existing routes (1.01 KB, patch)
2008-01-23 12:02 EST, Gary Thomas
no flags Details | Diff

  None (edit)
Description Gary Thomas 2008-01-22 16:57:33 EST
Description of problem:

Trying an NFS install using a kickstart file from HTTP fails

Version-Release number of selected component (if applicable):

11.4.0.23 (rawhide 2008-01-22)

How reproducible:

100%

Steps to Reproduce:
1. Start installer using ks=http:<URL>
2.
3.
  
Actual results:

Fails after reading kickstart file when trying to initialize network
to mount NFS images

Expected results:


Additional info:

The problem is that after fetching the kickstart file via the
network, the network is not totally torn down.  When NFS mount
tries to start up, it tries to reinitialize the network via DHCP
which fails because there are extant overlapping routes.

The kickstart file I used is a virgin one obtained by installing
rawhide today and then saving to a web URL.
Comment 1 Gary Thomas 2008-01-22 16:57:33 EST
Created attachment 292559 [details]
kickstart image
Comment 2 Gary Thomas 2008-01-23 12:02:27 EST
Created attachment 292671 [details]
Handle re-add of existing routes

Tested with libdhcp-1.99.5-1.fc8.src.rpm
Comment 3 David Cantrell 2008-01-23 20:47:56 EST
Thanks for the patch.  It's in libdhcp-1.99.7 now, which will appear in rawhide
as libdhcp-1.99.7-1.fc9.
Comment 4 Gary Thomas 2008-01-24 13:31:03 EST
Alas rawhide (i386) 2008-01-24 doesn't boot - "/init not found"

ISO: 2008-01-24 03:50
MD5: 1bea1b85c0fd7dcbe838a4da0c44513d
Comment 5 David Cantrell 2008-01-24 16:54:27 EST
That would be a different bug.  Tree compose failure, most likely.

Note You need to log in before you can comment on or make changes to this bug.