Bug 429767 - Rawhide install onto gfs2 fails
Rawhide install onto gfs2 fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Steve Whitehouse
Fedora Extras Quality Assurance
:
Depends On: 220052
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 17:15 EST by Eric Sandeen
Modified: 2008-03-12 18:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 18:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2008-01-22 17:15:31 EST
Installing onto gfs2 from rawhide, kernel 2.6.24-0.157.rc8.fc9, fails with a
backtrace; didn't capture the console but it looks like a BUG: softlockup sort
of thing.
Comment 1 Eric Sandeen 2008-01-31 16:47:44 EST
here's the oops:

------------[ cut here ]------------
kernel BUG at fs/gfs2/glock.c:1119!
invalid opcode: 0000 [#1] SMP 
Modules linked in: sha256_generic aes_generic cbc blkcipher dm_crypt dm_emc
dm_round_robin dm_multipath dm_snapshot dm_mirror dm_zero dm_mod xfs jfs
reiserfs lock_nolock gfs2 msdos linear raid10 raid456 async_xor async_memcpy
async_tx xor raid1 raid0 sg sr_mod cdrom sd_mod ata_generic ata_piix pata_acpi
e100 mii libata ehci_hcd uhci_hcd ipv6 iscsi_tcp libiscsi scsi_transport_iscsi
scsi_mod ext2 ext3 jbd ext4dev jbd2 mbcache crc16 squashfs pcspkr edd floppy
loop nfs lockd nfs_acl sunrpc vfat fat cramfs

Pid: 1658, comm: ldconfig Not tainted (2.6.24-2.fc9 #1)
EIP: 0060:[<debc941f>] EFLAGS: 00210282 CPU: 0
EIP is at gfs2_glock_nq+0x10d/0x1ad [gfs2]
EAX: 00000020 EBX: d3b54e0c ECX: c0427db6 EDX: c1a26000
ESI: c462088c EDI: c87b2a00 EBP: d3b54ce4 ESP: d3b54cc0
 DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process ldconfig (pid: 1658, ti=d3b54000 task=c1a26000 task.ti=d3b54000)
Stack: debdff82 00000003 00000001 c87b2a00 c7b4c000 00000000 0001f528 c462088c 
       d53cc980 d3b54d5c debdaa15 c462088c 00000000 00000000 000002d0 debe184b 
       c46204b8 c7b4c000 c46207b4 00000000 c04e4367 c1a26000 c46204b8 c7b4c4d4 
Call Trace:
 [<c0406b47>] show_trace_log_lvl+0x1a/0x2f
 [<c0406bf7>] show_stack_log_lvl+0x9b/0xa3
 [<c0406ca6>] show_registers+0xa7/0x178
 [<c0406eac>] die+0x135/0x220
 [<c0640814>] do_trap+0x8a/0xa3
 [<c0407256>] do_invalid_op+0x88/0x92
 [<c06405c2>] error_code+0x72/0x80
 [<debdaa15>] gfs2_inplace_reserve_i+0x1f5/0x56b [gfs2]
 [<debd497b>] gfs2_rename+0x40c/0x664 [gfs2]
 [<c049ac39>] vfs_rename+0x273/0x3ed
 [<c049c710>] sys_renameat+0x174/0x1d9
 [<c049c79d>] sys_rename+0x28/0x2a
 [<c0405292>] syscall_call+0x7/0xb
 =======================
Code: 0c c7 04 24 75 ff bd de 89 44 24 04 e8 88 7f 86 e1 8b 47 3c 8b 57 14 89 44
24 08 89 54 24 04 c7 04 24 82 ff bd de e8 6e 7f 86 e1 <0f> 0b eb fe 39 58 0c 74
0e 89 d0 8b 10 0f 18 02 90 39 c8 75 ef 
EIP: [<debc941f>] gfs2_glock_nq+0x10d/0x1ad [gfs2] SS:ESP 0068:d3b54cc0
---[ end trace 2d4f1c8a3d22756d ]---
BUG: soft lockup - CPU#0 stuck for 11s! [gfs2_scand:1208]
Comment 2 Steve Whitehouse 2008-02-01 03:19:56 EST
Ah, that was fixed yonks ago upstream, its just that I can't easily update the
kernel in Fedora until they start to use 2.6.24 since there is a lot of
difference due to the write_begin/write_end code. As soon as they move to a
2.6.24 base, then this will be fixed.
Comment 3 Eric Sandeen 2008-02-01 09:48:14 EST
Pid: 1658, comm: ldconfig Not tainted (2.6.24-2.fc9 #1)
                                       ^^^^^^

It is 2.6.24

-Eric
Comment 4 Steve Whitehouse 2008-02-01 09:55:36 EST
Ah, oops. Then it means that I need to send them the update that I've been
waiting to send them. Last time I checked the Fedora CVS it hadn't been updated.
I'll try and sort that out as soon as I can (which might be Tuesday now).
Comment 5 Eric Sandeen 2008-02-01 09:59:56 EST
Ok - rawhide really pretty well follows git, with brief pauses now and then, so
generally if something is busted in rawhide kernels, it's busted upstream.
Comment 7 Eric Sandeen 2008-02-01 10:53:53 EST
Ok, that patch is in the 2.6.25 stream, it went in just 7 days ago (despite the
Nov 7 date in your git tree, I guess)

So perhaps when Fedora gets back on the git-stream in a couple days.

Thanks,
-Eric
Comment 8 Steve Whitehouse 2008-03-12 12:29:52 EDT
Is this fixed for you now? If not I'll get it back on the list to look into.
Comment 9 Eric Sandeen 2008-03-12 12:38:07 EDT
Was just going to test it today, actually :)

-Eric
Comment 10 Eric Sandeen 2008-03-12 18:24:24 EDT
With today's rawhide (roughly F9 beta), which has a 2.6.25 kernel, install
completed.  Haven't booted yet, if there's any trouble I'll let you know :)

-Eric

Note You need to log in before you can comment on or make changes to this bug.