Bug 429769 - gfs2-utils in rawhide significantly lags RHEL5
gfs2-utils in rawhide significantly lags RHEL5
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gfs2-utils (Show other bugs)
rawhide
All Linux
urgent Severity low
: ---
: ---
Assigned To: Steve Whitehouse
Fedora Extras Quality Assurance
:
: 237538 (view as bug list)
Depends On:
Blocks: 224154 225792 237538 239773 433592
  Show dependency treegraph
 
Reported: 2008-01-22 17:17 EST by Eric Sandeen
Modified: 2008-04-21 12:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 12:04:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2008-01-22 17:17:51 EST
Rawhide has gfs2-utils 0.1.9; rhel5 has gfs2-utils 0.1.43

This is backwards; rawhide should have the bleeding edge code.   (it will
eventually be RHEL6, after all)
Comment 1 Steve Whitehouse 2008-01-23 04:33:19 EST
Its not uptodate kernel-wise either. That will change after the next merge
window and is due to the rather complicated VFS changes surrounding
write_begin/write_end which will not get pulled into Fedora until 2.6.25 final
is out. As soon as that has been released I'll send a big update and we'll be
uptodate again.
Comment 2 Eric Sandeen 2008-01-23 09:10:42 EST
Have you changed disk format since 0.1.9?  Is there any reason that 0.1.43
should not work as well as 0.1.9?

-Eric
Comment 3 Steve Whitehouse 2008-01-23 09:16:47 EST
I don't think anything much has changed since then to be honest. There is no
reason to hold back the utils upgrade just because the kernel is held back for a
week or two.
Comment 4 Eric Sandeen 2008-01-23 09:51:40 EST
Actually, looks like there was an on-disk quota change in there somewhere,
adding qu_ll_next.  Probably OK on rawhide, but not there in F8 yet I think.
Comment 5 Eric Sandeen 2008-02-14 00:25:16 EST
ok actually rawhide has 0.1.25 not 0.1.9; that dir is empty (?) :)
Comment 6 Robert Peterson 2008-03-12 11:41:44 EDT
*** Bug 237538 has been marked as a duplicate of this bug. ***
Comment 7 Steve Whitehouse 2008-03-14 09:25:35 EDT
How far along the road are we in getting this package updated in Fedora?
Comment 8 Chris Feist 2008-03-14 17:57:18 EDT
I'm working on it right now, I'm working through the F8 issues, but it should be
built soon.
Comment 9 Steve Whitehouse 2008-03-31 08:49:35 EDT
Is this ready yet?
Comment 10 Chris Feist 2008-03-31 11:27:02 EDT
I'm ready to rebuild, but I am unable to get the proper
permissions/software/assistance to get the packages built in the new Fedora
build system.  I am working on finding someone who can help me, but it is not easy.
Comment 11 Steve Whitehouse 2008-04-04 09:01:26 EDT
From the build log which says:

+ ./configure --kernel_src=/usr --libdir=/usr/lib
/var/tmp/rpm-tmp.23731: line 27: ./configure: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.23731 (%build)

I would guess that the problem is due to the incorrect spec file. It should be
%configure rather than ./configure I think. Also why are we adding the
gfs2_ondisk.h file as a patch? This should be available from the kernel headers
package.

Please can you add me as co-maintainer of the gfs2-utils package (the Fedora
guidelines say that we should have at least two maintainers).

Btw, the URL in the spec file is also wrong and needs updating.
Comment 12 Steve Whitehouse 2008-04-04 09:41:13 EDT
Also from the fedora packaging guidelines:

make ought to be make %{?_smp_mflags}

Also we should look into making our static libraries shared too (which is bz
#408631 for libgfs2, but there isn't as yet a bz against libvolumne_id) as that
is about the only other area I could spot where we are not fully in agreement
with the packaging guidelines.
Comment 13 Steve Whitehouse 2008-04-04 10:42:50 EDT
Also configure uses perl and I don't see a build dep for perl in the spec file.
Comment 14 Eric Sandeen 2008-04-04 11:35:52 EDT
If you're looking at the specfile, may as well clean up the rpmlint problems
too, perhaps:

# rpmlint /usr/src/redhat/RPMS/i386/gfs2-utils-0.1.25-2.fc9.i386.rpm 
gfs2-utils.i386: W: spurious-executable-perm /usr/share/man/man8/gfs2_convert.8.gz
gfs2-utils.i386: W: spurious-executable-perm /usr/share/man/man8/gfs2_fsck.8.gz
gfs2-utils.i386: W: spurious-executable-perm /usr/share/man/man8/gfs2_mount.8.gz
gfs2-utils.i386: W: spurious-executable-perm /usr/share/man/man8/gfs2_tool.8.gz
gfs2-utils.i386: W: spurious-executable-perm /usr/share/man/man8/mkfs.gfs2.8.gz
gfs2-utils.i386: W: spurious-executable-perm /usr/share/man/man8/gfs2_grow.8.gz
gfs2-utils.i386: W: spurious-executable-perm /usr/share/man/man8/gfs2_quota.8.gz
gfs2-utils.i386: W: spurious-executable-perm /usr/share/man/man8/gfs2_jadd.8.gz
gfs2-utils.i386: W: spurious-executable-perm /usr/share/man/man8/gfs2.8.gz
gfs2-utils.i386: W: invalid-license GPL
gfs2-utils.i386: E: missing-mandatory-lsb-keyword Description in
/etc/rc.d/init.d/gfs2
gfs2-utils.i386: E: missing-mandatory-lsb-keyword Short-Description in
/etc/rc.d/init.d/gfs2
gfs2-utils.i386: W: incoherent-init-script-name gfs2

(license needs to be GPLv2, GPLv2+, GPLv3, etc......)
Comment 15 Steve Whitehouse 2008-04-04 11:43:05 EDT
... and even adding the version to the GPL doesn't tell the whole story as I
assume that we'd want to make the libgfs2 LGPL.
Comment 16 Eric Sandeen 2008-04-04 11:56:23 EDT
then "GPLv2 and LGPLv2" or something along those lines works...
Comment 17 Kroum Antov 2008-04-10 16:51:49 EDT
Any progress on this will be greatly appreciated!
When do you expect release for F9? How about F8?
Comment 18 Steve Whitehouse 2008-04-11 03:25:15 EDT
There is an rpm in testing for F-8 atm. Its a fairly quick update and as soon as
I can resolve a couple more issues, then I'll do another release for F-8, F-9
and devel. It shouldn't be too long now I hope, sorry for the delay.
Comment 19 Steve Whitehouse 2008-04-14 06:01:07 EDT
Fixed. New update on its way.
Comment 20 Steve Whitehouse 2008-04-17 03:58:52 EDT
This is now released in F-8. The rawhide/F-9 build has been done, but I'm not
sure how long it takes to actually appear on the mirrors now.

Note You need to log in before you can comment on or make changes to this bug.