Bug 429780 - gnome-volume-manager ignores its settings
gnome-volume-manager ignores its settings
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 17:46 EST by Michal Jaegermann
Modified: 2015-03-03 17:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 08:14:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-01-22 17:46:02 EST
Description of problem:

In gconf I have, clearly visible in a output of gconftool-2, for
/desktop/gnome/volume_manager
    autoopen = false
    autobrowse = false
    autorun = false

Despite of that, after recent updates, inserting a CD into a drive
gets me a dialog "This media contains software intended to be
automatically started.  Would you like to run it?".  Definitely
not and under NO circumstances.  The question is misplaced.

If, with another CD, this dialog does not show up then an unwanted
browser window automatically pops-out.

Moreover options which allowed to change that EXTREMELY UNDESIRABLE
behaviour, and where defaults should be really the other way around,
vanished from "Removable Drives and Media" preference menus.

Version-Release number of selected component (if applicable):
gnome-volume-manager-2.22.0-2.fc9

How reproducible:
all the time
Comment 1 David Zeuthen 2008-02-15 16:30:36 EST
Automounting + Autorunning programs is now handled by Nautilus. There's both UI
and gconf keys to customize / disable this.
Comment 2 Michal Jaegermann 2008-02-17 17:37:16 EST
> Automounting + Autorunning programs is now handled by Nautilus. There's
> both UI and gconf keys to customize / disable this.

I spent some time today looking for this mythical UI and so far
I drew blank.  There is definitely nothing under
"Preferences->Hardware->Removable Drives and Media" where
anything of a kind "drives" is not even mentioned.  I tried
other possibilities too and so far I am out of luck.

Scanning through and ouput of 'gconftool-2 -R /' was also of not
much help.  I cannot exclude that on this long list indeed there
is something but nothing which would for me be even remotely "obvious".

Therefore I would highly appreciate some more specific information
than "oh, there is something somewhere" from comment #1.  If this is
indeed the case, and I cannot find it after a prolonged search, then
I see that as a serious BUG.

Another bug is an obvious regression.  I had a system configured
to behave in a certain way, something got updated, and my configuration
was not carried over; even if some other component took over those
duties.  That should not happen.

Last but not least I was told on numerous occassions that if I am
not sure what is responsible for a broken behaviour I should file
a bug anyway and developers later will sort out correct components
and assignees later.  Closing bugs because I have a component wrong
directly contradicts this information.  I would rather not play
"whack-a-mole" with that.  Thank you!
Comment 3 David Zeuthen 2008-02-18 08:14:23 EST
Sorry, but this is Fedora; there is no expectation of settings being preserved
from one version to another.

The UI is in the Nautilus preference UI, it's at
System->Preferences->Personal->File Management. Then it's the tab called
"Media". The gconf settings are in apps->nautilus->preferences under media_*.

Btw, there was no need to reopen this bug just because you feel that someone is
obligated to answer questions that could be answered by you doing some simple
research.
Comment 4 Michal Jaegermann 2008-02-18 12:52:43 EST
> Sorry, but this is Fedora;

So you are saying that if one day we will see instead of a desktop
an interface to your washing machine then this will be ok.  Right?

> System->Preferences->Personal->File Management

Yeah, totally clear to everybody that removable media will be
under "File Management".  I wonder why not under
"Look and Feel->Screensaver"?  Also a good and "obvious" place.

Still if you would tell that right away everybody would waste much
less time.

> There's both UI and gconf keys to customize / disable this.

And for everybody should be crystal clear that an addition of
'x-content/software' to 'media_autorun_x_content_ignore' list is
what is required to fix a broken default behaviour and that even
when 'x-content/software' key is not showing up in any other context.
Sorry but I am not imaginative enough for that.



Note You need to log in before you can comment on or make changes to this bug.