Bug 429796 - yum upgrade from f8 to rawhide problem with openssl and libc-client2006
yum upgrade from f8 to rawhide problem with openssl and libc-client2006
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: uw-imap (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 21:07 EST by Bruno Wolff III
Modified: 2008-01-23 12:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 12:53:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2008-01-22 21:07:49 EST
Description of problem:
When I attempt a yum upgrade I get the following message:
ERROR with rpm_check_debug vs depsolve:
Package libc-client2006 needs libcrypto.so.6, this is not available.
Package libc-client2006 needs libssl.so.6, this is not available.

Version-Release number of selected component (if applicable):
libc-client2006-2006k-1.fc8
openssl-0.9.8g-3.fc9

How reproducible:
I have been hitting these problems one at a time removing the obsolete packages
and trying again. This normally solves the problem, but doesn't tell me much
about reproducibillity

Steps to Reproduce:
1. install libc-client in F8
2. add/enable the rawhide repository
3. yum upgrade
  
Actual results:
The upgrade fails with the above message.

Expected results:
The upgrades succeeds.

Additional info:
Since libc-client2006 isn't in rawhide, something likely superceded it and it
can probably be obsoleted.
Comment 1 Bruno Wolff III 2008-01-22 21:23:37 EST
When I removed libc-client2006 the only thing it took with it was php-imap which
suggests that php-map is what should be obsoleting libc-client2006.
I am changing the component to php (as php-imap isn't a valid choice) since that
maintainer will probably be a better person to judge than the openssl maintainer.
Comment 2 Rex Dieter 2008-01-23 07:40:56 EST
I'll add the Obsoletes to the latest libc-client*.
Comment 3 Rex Dieter 2008-01-23 12:53:00 EST
* Wed Jan 23 2008 Rex Dieter <rdieter@fedoraproject.org> 2007-2
- Obsoletes: libc-client2006 (#429796)

Note You need to log in before you can comment on or make changes to this bug.