This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 429854 - Can't change password with ipa-passwd
Can't change password with ipa-passwd
Status: CLOSED NOTABUG
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Karl MacMillan
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-23 09:43 EST by David O'Brien
Modified: 2015-01-04 18:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 09:58:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David O'Brien 2008-01-23 09:43:29 EST
Description of problem:
Taken from email:

> ipa-passwd
> - how is this different from kpasswd and when should we use one or the 
> other?
>
> - I tried this logged in as jsmith:
> [redhat@darwin sbin]$ klist
> Ticket cache: FILE:/tmp/krb5cc_500
> Default principal: jsmith@AUSTRALIA.COM
>
> Valid starting     Expires            Service principal
> 01/23/08 17:50:34  01/24/08 17:50:30  krbtgt/AUSTRALIA.COM@AUSTRALIA.COM
> 01/23/08 17:51:06  01/24/08 17:50:30  
> HTTP/darwin.australia.com@AUSTRALIA.COM
>
> Kerberos 4 ticket cache: /tmp/tkt500
> klist: You have no tickets cached
> [redhat@darwin sbin]$ ./ipa-passwd jsmith
> Changing password for jsmith@AUSTRALIA.COM
>  New Password:
>  Confirm Password:
> A database error occurred: Insufficient access: Insufficient access rights
>
> Does ipa-passwd only work for admin?
>
ipa-passwd talks XML-RPC. kpasswd talks to the KDC directly. They are 
probably interchangable.

ipa-passwd should let you change your own password. Can you file a bug 
on this? We did a bunch of ACL changes after the initial development and 
it looks like the screws were turned a little too tight.

Version-Release number of selected component (if applicable):
ipa-server-0.6.0-2

How reproducible:
Always?

Note You need to log in before you can comment on or make changes to this bug.