This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 429886 - udev rules after pdate are missing GROUP= support
udev rules after pdate are missing GROUP= support
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-23 11:42 EST by Joe Acosta
Modified: 2013-03-05 22:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 10:29:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Acosta 2008-01-23 11:42:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Description of problem:
I was not able to set the volume controls in gnome via the gnome volume applet.  After researching this, I discovered I could do this as root but not a normal user.


Version-Release number of selected component (if applicable):
udev-x.x.x

How reproducible:
Always


Steps to Reproduce:
1. update to the latest fedora core 8 as of 1/21/2008
2. log in as a user other than root
3. add gnome volume applet ( assuming you can log into gnome but that is another bug )
4. the volume icon shows a red x and does not work
5. click it and it will tell you something about gstreamer volume plugin missing
6. it is lieing!

Actual Results:
the icon shows a red x and does not work for the volume control

Expected Results:
it should work like it was working.  I know my sound card is supported

Additional info:
After deleting .gstreamer* directories and I get:

No volume control GStreamer plugins and/or devices found. 

When I try to go into user prefs -> sound.  Then I hit test on any of the buttons I then get:

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink:
Internal GStreamer error: state change failed.  Please file a bug at
http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer.

This makes it sound like there is an issue with gstreamer, but there is no problem with gstreamer.  The problem turns out that there is no group "audio" anymore in the /etc/group file.  Also the also udev rules are missing a GROUP="audio" in it also.

so the udev rules ( 40-alsa.rules ) have:

    KERNEL=="controlC[0-9]*",	NAME="snd/%k"

but need:

    KERNEL=="controlC[0-9]*",	NAME="snd/%k", GROUP="audio"

in order for a user in the group audio to run work with sound.

Was this one of those 'someone changed how this is supposed to work in the middle of a release thing' or something else?  Is there now some /etc/sysconfig thing that needs to be setup?

The reason I am filing this as a bug, is because even though I can fix it, the udev rules file says that the file will be overwritten at the next update so do not edit it.
Comment 2 Joe Acosta 2008-01-23 23:45:09 EST
udev version that this is in is udev-118-1.fc8
Comment 3 Ray Strode [halfline] 2008-02-12 10:29:57 EST
See bug 529475, Joe wasn't running ConsoleKit.

Note You need to log in before you can comment on or make changes to this bug.