Bug 429894 - blank screen on P4M890
blank screen on P4M890
Status: CLOSED DUPLICATE of bug 391621
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-23 12:21 EST by Leonid Kanter
Modified: 2008-02-14 15:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 15:55:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log (49.37 KB, text/plain)
2008-01-23 12:21 EST, Leonid Kanter
no flags Details
xorg.conf (622 bytes, text/plain)
2008-01-23 12:27 EST, Leonid Kanter
no flags Details
OpenGL overlay screen (145.03 KB, image/jpeg)
2008-01-24 07:13 EST, Leonid Kanter
no flags Details
Xv overlay screen (178.84 KB, image/jpeg)
2008-01-24 07:14 EST, Leonid Kanter
no flags Details

  None (edit)
Description Leonid Kanter 2008-01-23 12:21:14 EST
Description of problem:

Blank screen after X server start on P4M900

Version-Release number of selected component (if applicable):

xorg-x11-drv-openchrome-0.2.901-5.fc9xorg-x11-drv-openchrome-0.2.901-5.fc9

How reproducible:

always

Steps to Reproduce:
1. configure xorg.conf for using openchrome driver
2. start X

  
Actual results:

Blank screen

Expected results:

X cursor in the screen center

Additional info:

no errors in Xorg.0.log
Comment 1 Leonid Kanter 2008-01-23 12:21:14 EST
Created attachment 292674 [details]
X server log
Comment 2 Leonid Kanter 2008-01-23 12:27:40 EST
Created attachment 292676 [details]
xorg.conf
Comment 3 Leonid Kanter 2008-01-23 12:29:06 EST
Hardware is ASUS P5V-VM ULTRA motherboard
Comment 4 Xavier Bachelot 2008-01-23 14:53:44 EST
Your conf says driver 'nv', whereas it should obviously be 'openchrome'.
Anyway, I've pushed a build with a P4M900 related fix.
Available here if you want to test it before it's in Rawhide :
http://koji.fedoraproject.org/koji/taskinfo?taskID=368318
Comment 5 Leonid Kanter 2008-01-24 07:13:36 EST
Created attachment 292791 [details]
OpenGL overlay screen
Comment 6 Leonid Kanter 2008-01-24 07:14:43 EST
Created attachment 292792 [details]
Xv overlay screen
Comment 7 Leonid Kanter 2008-01-24 07:27:54 EST
Good time of day,
Sorry for wrong xorg.conf, Xorg.0.log was correct.
With this new driver, xorg-x11-drv-openchrome-0.2.901-6.fc9.i386.rpm, 2D works
perfectly. 3D works somehow too, performance is good, but OpenGL overlay window
have some defects - see attachment id=292791. As for Xv, it's still broken. I
tried to play movie using mplayer -vo xv. After 2-4 seconds of playback overlay
window bacame green and system locked. See other attachment. Anyway, now I can
use this sandbox system without nvidia card and noise level and power
consumption are much lover, thank you very much!
My card is actually P4M890, not 900. Device ID 1106:3343 (rev 02)
Comment 8 Xavier Bachelot 2008-02-14 15:55:08 EST
sorry for the late answer. The Xv bug with libpciaccess enabled driver is known.
I'm closing this bug as a duplicate to another similar issue.

*** This bug has been marked as a duplicate of 391621 ***

Note You need to log in before you can comment on or make changes to this bug.