Bug 429929 - Wide messages scroll right when displayed
Wide messages scroll right when displayed
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-23 15:44 EST by Christopher Beland
Modified: 2008-03-16 18:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-16 18:02:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 522837 None None None Never

  None (edit)
Description Christopher Beland 2008-01-23 15:44:41 EST
Occasionally I receive e-mails with words, such as URLs, which are longer than
the usual 80 or so characters.  (Often these messages are also very long
vertically.)  When I view such a message in Evolution, the viewer scrolls right.
 If I scroll left while the message is still rendering, it scrolls right again.

I would expect to see the leftmost part of such messages at the end of the
rendering process, since English reads left-to-right.  Scrolling right should
only be done manually.

evolution-2.12.3-1.fc8
Comment 1 Milan Crha 2008-01-24 11:58:39 EST
I cannot reproduce this consistently, furthermore, it did to me only once. When
I started to investigate it more, it started to act as expected. I suspect that
some part of the code changed horizontal scroll bar position beyond the
document's limit, so GtkHtml thought you have scrolled to the right already, but
too much to the right, so it decided to correct it to maximal right for the
rendered document. Which is the right thing in case you did move to the right by
hand, not by program itself.

As I said above, I cannot reproduce it again, maybe some race condition or
something, in GtkHtml probably (I suspect gtk_html_private_calc_scrollbars).
Comment 2 Matthew Barnes 2008-02-13 23:49:14 EST
Also, just to make sure this isn't another case of Caret Mode malfunctioning,
check whether View -> Caret Mode is enabled.
Comment 3 Christopher Beland 2008-02-14 09:05:59 EST
Caret mode is disabled; I've never used it.
Comment 4 Matthew Barnes 2008-03-16 18:02:10 EDT
Moving this upstream.  Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=522837

Note You need to log in before you can comment on or make changes to this bug.